Solr
  1. Solr
  2. SOLR-3876

Solr Admin UI is completely dysfunctional on IE 9

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0-BETA, 4.0
    • Fix Version/s: 4.1
    • Component/s: web gui
    • Labels:
      None
    • Environment:

      Windows 7, IE 9

      Description

      The Solr Admin UI is completely dysfunctional on IE 9. See attached screen shot. I don't even see a "collection1" button. But Admin UI is working fine in Google Chrome with same running instance of Solr.

      Currently running 4.0 RC0, but problem existed with 4.0-BETA.

      1. screenshot-1.jpg
        64 kB
        Jack Krupansky
      2. screenshot-2.jpg
        65 kB
        Jack Krupansky
      3. screenshot-3.jpg
        140 kB
        Jack Krupansky
      4. SOLR-3876.patch
        4 kB
        Stefan Matheis (steffkes)
      5. SOLR-3876.patch
        3 kB
        Stefan Matheis (steffkes)

        Issue Links

          Activity

          Commit Tag Bot added a comment -

          [branch_4x commit] Stefan Matheis
          http://svn.apache.org/viewvc?view=revision&revision=1430589

          SOLR-3876: Solr Admin UI is completely dysfunctional on IE 9 (merge r1430586)

          Commit Tag Bot added a comment -

          [trunk commit] Stefan Matheis
          http://svn.apache.org/viewvc?view=revision&revision=1430586

          SOLR-3876: Solr Admin UI is completely dysfunctional on IE 9

          Stefan Matheis (steffkes) added a comment -

          Uhm, how does that work? *g I mean .. i want complain about that fact, but well

          Updated the initial Patch, the commits i made in the meantime changed a few lines. i'll commit that soon, so that this issue goes in for 4.1

          Jack Krupansky added a comment -

          I didn't see a commit go by, but when I checked on the XML query result display issue (SOLR-3840), the full Solr Admin UI seems to work just fine now, at least for the dozen or so screens I navigated through.

          I tested it with ant run-example with a fresh svn co of branch_4x just a couple of minutes ago.

          I still tried to apply the patch anyway, but I get a problem:

          Jack Krupansky@JackKrupansky lucene_solr_4x [master] $ patch -p0 -i SOLR-3876.patch
          patching file solr/webapp/web/admin.html
          patching file solr/webapp/web/js/lib/console.js
          patching file solr/webapp/web/js/scripts/cloud.js
          Hunk #1 succeeded at 436 (offset 21 lines).
          Hunk #2 succeeded at 446 (offset 21 lines).
          patching file solr/webapp/web/js/scripts/app.js
          Hunk #2 FAILED at 184.
          Hunk #3 FAILED at 227.
          Hunk #4 succeeded at 312 (offset 38 lines).
          2 out of 4 hunks FAILED -- saving rejects to file solr/webapp/web/js/scripts/app.js.rej
          patching file solr/webapp/web/js/scripts/plugins.js
          

          But if it works without that patch, who am I to complain.

          In any case, thanks for the huge improvement in 4.1 over 4.0 for IE support.

          Stefan Matheis (steffkes) added a comment -

          Even if not specifically mentioned, the same goes for Paul Alkema, Daniel Collins and all other IE users of course more tests (or at least confirmation) will help to bring this in for 4.1

          Jack Krupansky added a comment -

          Sure. I'll try to get to it this weekend.

          Stefan Matheis (steffkes) added a comment -

          Jack Krupansky would you mind giving this patch a shot? i have a IE 9.0 running in a Windows 7 VM and these few changes bring the whole UI back to working - at least for my setup.

          Mark Miller added a comment -

          the Solr documentation says that is supports Windows and so therefore should support the default windows browser correct?

          No, I don't think Solr running on windows means we require IE support. I do think we should make a best effort to get the basic working though. IE is still a major browser and the old admin UI worked with it. For an admin UI, I personally favor working in as many envs as possible (barring visual problems) over fancy looks or features.

          Paul Alkema added a comment - - edited

          I don't like IE as well however, the Solr documentation says that is supports Windows and so therefore should support the default windows browser correct? I'm wondering if it's the version of RequireJS used in the solr admin. It looks like it's RequireJS 1.0.6 but the latest version is RequireJS 2.1.2.

          Yonik Seeley added a comment -

          FWIW, I'm certainly not objecting to putting IE support in, I don't know why anyone would.

          To support those users who do (or have to) use IE, or are installing Solr on a server where only IE is installed?
          Although I don't think it should hold up a release, we shouldn't send a message that we don't care at all.

          Erick Erickson added a comment -

          FWIW, I'm certainly not objecting to putting IE support in, I don't know why anyone would. That said, I'm not willing to

          1> put the effort into it myself (partly due to my total lack of browser programming expertise)
          or
          2> hold up a release to put it in.

          Jack Krupansky added a comment -

          And even I (who filed the Jira) don't use IE for general web browsing on Windows, but I do keep IE as my default browser to assure that I test a fairly basic user scenario.

          Mark Miller added a comment -

          I don't care if everything is pretty or not, but we should at least support basic admin functionality in IE IMO (though I have not used it for years for just about anything).

          Paul Alkema added a comment -

          For those who use Windows Servers, this means you can't access the the Solr admin from localhost. This is a serious problem as most companies have policies against installing 3rd party browsers on production servers and I don't want to open up this admin to the public.

          Erick Erickson added a comment -

          FWIW, I don't think supporting all browsers was ever a goal. This isn't an public-facing app, devs use it. So I don't think it's unreasonable to say "works best in Chrome, no planned support for other browsers".

          Supporting the quirks of various browsers is such a rat-hole that I'm reluctant to even try. Especially since downloading Chrome and using it isn't that big a deal IMO, developers are the ones using the admin UI after all.

          Yes, IE is on lots of desktops. Yes, some corporate policies dictate that you can't use other browsers. Yes, it would be nice if it worked in IE. No, I'm not willing to put any effort that direction <G>...

          my $0.02

          Daniel Collins added a comment -

          For what its worth, IE 8 is just as bad.

          Hoss Man added a comment -

          This is actually a dup of SOLR-3841 but since this issue has more comments & screnshots i'll resolve that one.

          The one key comment from that issue to bear in mind...

          Yonik Seeley added a comment - 24/Sep/12 18:18

          Just to try and quantify the severity of the issue, I quickly checked the browser stats for solr downloads - it looks like IE is running at about 17%

          Christian Moen added a comment -

          The 4.0 UI wasn't developed with IE9 in mind so getting IE9 supported seems like a bigger effort. SOLR-3841 seems related to this issue and has been deferred to 4.1 so I'm suggesting that we do the same with this one as well.

          Please feel free to jump in with whatever comments you might have, steffkes.

          Jack Krupansky added a comment -

          I primarily use Chrome, so I never actually tried the Admin UI in IE 9 until recently - see my comment on SOLR-3840 dated September 13th. As indicated there, I meant to file a separate Jira for this issue, but... it slipped my mind until a was reviewing the comments on SOLR-3840 this morning when someone commented on that issue.

          I wasn't even aware that I had IE 9 - Microsoft must have pushed an auto-update at some point. The Wikipedia says IE 9 was released back in 2011, but that doesn't say when it became the default update for Windows 7.

          In short, I don't know if this is a regression for IE 9. I'd assume that it isn't. I don't even know if it is a regression from IE 8.

          Christian Moen added a comment - - edited

          Thanks a lot for this, Jack.

          I'm afraid I don't know the overall status nor history of the 4.0 UI in IE9, but do you happen to know if this is a regression of it the UI has been generally broken for IE9 all along?

          To me it sounds quite important to get this fixed for 4.0 if it's a regression. I can help working some on this.

          Jack Krupansky added a comment -

          And for reference, here is a screenshot of Admin in Chrome running against the same Solr instance as IE 9.

          Jack Krupansky added a comment -

          After hitting browser refresh the Admin appearance changes a little, but still no "collection1" button.


            People

            • Assignee:
              Stefan Matheis (steffkes)
              Reporter:
              Jack Krupansky
            • Votes:
              3 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development