Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-3679

Core Admin UI gives no feedback if "Add Core" fails

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: None
    • Component/s: Admin UI
    • Labels:
      None

      Description

      • start the example
      • load the admin ui, click on core admin
      • click on "Add Core"
      • fill the form out with giberish and submit.

      The form stays on the screen w/o any feedback that an error occurred

      1. SOLR-3679.patch
        7 kB
        Hoss Man
      2. SOLR-3679.patch
        3 kB
        Stefan Matheis (steffkes)

        Activity

        steffkes Stefan Matheis (steffkes) added a comment -

        Combined Patch for SOLR-3680 and SOLR-3679

        The current Error Message seems to wrap the original Exception so that we always get the same Text?

        Complete Stacktrace:

        SEVERE: org.apache.solr.common.SolrException: Error executing default implementation of CREATE
        	at org.apache.solr.handler.admin.CoreAdminHandler.handleCreateAction(CoreAdminHandler.java:389)
        	at org.apache.solr.handler.admin.CoreAdminHandler.handleRequestBody(CoreAdminHandler.java:134)
        	at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:129)
        	at org.apache.solr.servlet.SolrDispatchFilter.handleAdminRequest(SolrDispatchFilter.java:371)
        	at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:180)
        	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1337)
        	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:484)
        	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
        	at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:524)
        	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:233)
        	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1065)
        	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:413)
        	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:192)
        	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:999)
        	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
        	at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:250)
        	at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149)
        	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)
        	at org.eclipse.jetty.server.Server.handle(Server.java:351)
        	at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:454)
        	at org.eclipse.jetty.server.BlockingHttpConnection.handleRequest(BlockingHttpConnection.java:47)
        	at org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:890)
        	at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:944)
        	at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:634)
        	at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:230)
        	at org.eclipse.jetty.server.BlockingHttpConnection.handle(BlockingHttpConnection.java:66)
        	at org.eclipse.jetty.server.bio.SocketConnector$ConnectorEndPoint.run(SocketConnector.java:254)
        	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:599)
        	at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:534)
        	at java.lang.Thread.run(Thread.java:722)
        Caused by: java.io.IOException: Can't find resource 'solrconfig.xml' in classpath or 'solr/new_core/conf/', cwd=/opt/solr/trunk/solr/example
        	at org.apache.solr.core.SolrResourceLoader.openResource(SolrResourceLoader.java:317)
        	at org.apache.solr.core.SolrResourceLoader.openConfig(SolrResourceLoader.java:283)
        	at org.apache.solr.core.Config.<init>(Config.java:111)
        	at org.apache.solr.core.Config.<init>(Config.java:78)
        	at org.apache.solr.core.SolrConfig.<init>(SolrConfig.java:117)
        	at org.apache.solr.core.CoreContainer.create(CoreContainer.java:780)
        	at org.apache.solr.handler.admin.CoreAdminHandler.handleCreateAction(CoreAdminHandler.java:384)
        	... 29 more
        hossman Hoss Man added a comment -

        we always get the same Text?

        yeah, that error message is terrible (i suspect we have alot of terrible messages because people always assumed you'd have the full stack trace to look at in a log file, w/o considering a UI case like this)

        I update your patch to include an improved error message in the CoreAdminHandle – if you're happy with the UI side of things, go ahead and commit whenever you're ready.

        steffkes Stefan Matheis (steffkes) added a comment -

        Hoss, not sure if the included change to solr/example/solr/solr.xml is really wanted? If so, just let me know and i'll commit this.

        hossman Hoss Man added a comment -

        Bah .. no, must have been from manual testing with the example - ignore any solr.xml changes.

        steffkes Stefan Matheis (steffkes) added a comment -

        Committed revision 1381655. trunk
        Committed revision 1381656. 4x

        commit-tag-bot Commit Tag Bot added a comment -

        [branch_4x commit] Stefan Matheis
        http://svn.apache.org/viewvc?view=revision&revision=1381656

        SOLR-3679: admin ui shows error message if creating a new core fails


          People

          • Assignee:
            steffkes Stefan Matheis (steffkes)
            Reporter:
            hossman Hoss Man
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development