Solr
  1. Solr
  2. SOLR-3530

better error messages / Content-Type validation in solrJ

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.6, Trunk
    • Component/s: None
    • Labels:
      None

      Description

      spin off from SOLR-3258, it would be helpful if SolrJ, when encountering Exceptions from the ResponseParser (or perhaps before ever even handing data to the ResponseParser) did some validation of the Content-Type returned by the remote server to give better error messages in cases where miss configuration has the wrong matchup between ResponseParser and mime-type (or worse: an HTML page being returned by a non-solr server)

        Issue Links

          Activity

          Hoss Man created issue -
          Hoss Man made changes -
          Field Original Value New Value
          Link This issue is related to SOLR-3258 [ SOLR-3258 ]
          Mark Miller made changes -
          Assignee Mark Miller [ markrmiller@gmail.com ]
          Mark Miller made changes -
          Link This issue relates to SOLR-5291 [ SOLR-5291 ]
          Mark Miller added a comment -

          This is the root cause of the infamous "Invalid version (expected 2, but 60) or the data in not in 'javabin' format". I saw some of this while working on SOLR-5291 and am taking a stab at it as part of that issues patch.

          Mark Miller made changes -
          Fix Version/s 5.0 [ 12321664 ]
          Fix Version/s 4.6 [ 12325000 ]
          ASF subversion and git services added a comment -

          Commit 1527547 from Mark Miller in branch 'dev/trunk'
          [ https://svn.apache.org/r1527547 ]

          SOLR-5291: Solrj does not propagate the root cause to the user for many errors.
          SOLR-3530: Better error messages / Content-Type validation in SolrJ.

          ASF subversion and git services added a comment -

          Commit 1527554 from Mark Miller in branch 'dev/branches/branch_4x'
          [ https://svn.apache.org/r1527554 ]

          SOLR-5291: Solrj does not propagate the root cause to the user for many errors.
          SOLR-3530: Better error messages / Content-Type validation in SolrJ.

          Mark Miller made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          ASF subversion and git services added a comment -

          Commit 1527776 from Mark Miller in branch 'dev/trunk'
          [ https://svn.apache.org/r1527776 ]

          SOLR-3530: Handle content type correctly when a response parser cannot be used.

          ASF subversion and git services added a comment -

          Commit 1527780 from Mark Miller in branch 'dev/branches/branch_4x'
          [ https://svn.apache.org/r1527780 ]

          SOLR-3530: Handle content type correctly when a response parser cannot be used.

          ASF subversion and git services added a comment -

          Commit 1527784 from Mark Miller in branch 'dev/trunk'
          [ https://svn.apache.org/r1527784 ]

          SOLR-3530: Add missing 'throw'.

          ASF subversion and git services added a comment -

          Commit 1527786 from Mark Miller in branch 'dev/branches/branch_4x'
          [ https://svn.apache.org/r1527786 ]

          SOLR-3530: Add missing 'throw'.

          Hoss Man made changes -
          Link This issue breaks SOLR-5532 [ SOLR-5532 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          478d 13h 33m 1 Mark Miller 30/Sep/13 15:02

            People

            • Assignee:
              Mark Miller
              Reporter:
              Hoss Man
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development