Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-3478

DataImportHandler's Entity must have a name

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: 4.0-ALPHA
    • Component/s: None
    • Labels:
      None
    • Environment:

      r1341454,

      java -Dsolr.solr.home="./example-DIH/solr/" -jar start.jar

      Description

      Using trunk and trying to start the example-DIH version, throws the following Exception:

      May 22, 2012 8:17:45 PM org.apache.solr.common.SolrException log
      SEVERE: null:org.apache.solr.common.SolrException
        at org.apache.solr.core.SolrCore.<init>(SolrCore.java:614)
        [...]
      Caused by: org.apache.solr.handler.dataimport.DataImportHandlerException: Entity must have a name.
        at org.apache.solr.handler.dataimport.config.Entity.<init>(Entity.java:54)
        at org.apache.solr.handler.dataimport.config.DIHConfiguration.<init>(DIHConfiguration.java:61)
        at org.apache.solr.handler.dataimport.DataImporter.readFromXml(DataImporter.java:249)
        at org.apache.solr.handler.dataimport.DataImporter.loadDataConfig(DataImporter.java:187)
        ... 49 more
      1. SOLR-3478.patch
        0.7 kB
        Stefan Matheis (steffkes)

        Activity

        steffkes Stefan Matheis (steffkes) added a comment -

        Committed in r1341920

        steffkes Stefan Matheis (steffkes) added a comment -

        okay, now it's clear for me. will commit the changed example soon

        jdyer James Dyer added a comment -

        Actually I think for 4.0 we should break backwards-compatibility with this one and require all DIH entities to have a name. (In 3.6 and prior, it logs a warning and assigns a name based on the system clock.) In SOLR-3422 I fixed any unit tests that didn't use "name" but missed the examples.

        steffkes Stefan Matheis (steffkes) added a comment -

        Ah okay! I opened this issue, Credits to Emma, she reported this on the ML

        James will you take care of this one and i'll remove my patch, because this should not be required, right?

        jdyer James Dyer added a comment - - edited

        Thanks for finding this one. Looking at this issue, I'm pretty sure I introduced this bug with SOLR-3422.


          People

          • Assignee:
            steffkes Stefan Matheis (steffkes)
            Reporter:
            steffkes Stefan Matheis (steffkes)
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development