Solr
  1. Solr
  2. SOLR-3465

Replication Causes Two Searcher Warmups

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: 4.0, 6.0
    • Component/s: replication (java)
    • Labels:
      None

      Description

      I'm doing some testing with the current trunk, and am seeing that when a slave retrieves index updates from the master the warmup & searcher registration is performed twice. Here is a snippet of the log that demonstrates this:

      May 16, 2012 6:02:02 PM org.apache.solr.handler.SnapPuller fetchLatestIndex
      INFO: Total time taken for download : 92 secs
      May 16, 2012 6:02:02 PM org.apache.solr.core.SolrDeletionPolicy onInit
      INFO: SolrDeletionPolicy.onInit: commits:num=2
      commit{dir=/Users/mgarski/Code/indexes/solr2/geo/index,segFN=segments_1,generation=1,filenames=[segments_1]
      commit{dir=/Users/mgarski/Code/indexes/solr2/geo/index,segFN=segments_10,generation=36,filenames=[_45_0.tim, _45.fdt, segments_10, _45_0.tip, _45.fdx, _45.fnm, _45_0.frq, _45.per, _45_0.prx]
      May 16, 2012 6:02:02 PM org.apache.solr.core.SolrDeletionPolicy updateCommits
      INFO: newest commit = 36
      May 16, 2012 6:02:02 PM org.apache.solr.search.SolrIndexSearcher <init>
      INFO: Opening Searcher@559fe5e6 main
      May 16, 2012 6:02:02 PM org.apache.solr.core.QuerySenderListener newSearcher
      INFO: QuerySenderListener sending requests to Searcher@559fe5e6 main

      {StandardDirectoryReader(segments_10:335:nrt _45(4.0):C1096375)}

      May 16, 2012 6:02:02 PM org.apache.solr.core.QuerySenderListener newSearcher
      INFO: QuerySenderListener done.
      May 16, 2012 6:02:02 PM org.apache.solr.core.SolrCore registerSearcher
      INFO: [geo] Registered new searcher Searcher@559fe5e6 main

      {StandardDirectoryReader(segments_10:335:nrt _45(4.0):C1096375)}

      May 16, 2012 6:02:02 PM org.apache.solr.update.DirectUpdateHandler2 commit
      INFO: start commit

      {flags=0,version=0,optimize=false,openSearcher=true,waitSearcher=true,expungeDeletes=false,softCommit=false}

      May 16, 2012 6:02:02 PM org.apache.solr.search.SolrIndexSearcher <init>
      INFO: Opening Searcher@42101da9 main
      May 16, 2012 6:02:02 PM org.apache.solr.update.DirectUpdateHandler2 commit
      INFO: end_commit_flush
      May 16, 2012 6:02:02 PM org.apache.solr.core.QuerySenderListener newSearcher
      INFO: QuerySenderListener sending requests to Searcher@42101da9 main

      {StandardDirectoryReader(segments_10:335:nrt _45(4.0):C1096375)}

      May 16, 2012 6:02:02 PM org.apache.solr.core.QuerySenderListener newSearcher
      INFO: QuerySenderListener done.
      May 16, 2012 6:02:02 PM org.apache.solr.core.SolrCore registerSearcher
      INFO: [geo] Registered new searcher Searcher@42101da9 main

      {StandardDirectoryReader(segments_10:335:nrt _45(4.0):C1096375)}

      I am trying to determine the cause, does anyone have any idea where to start?

        Activity

        Michael Garski added a comment -

        I found the issue but am not sure what the appropriate fix would be.

        The SnapPuller.doCommit method does a solrCore.getSearcher and a solrCore.getUpdateHandler().commit... one of those may be redundant but I do not know which. I reverted the body of that method to an older version (1237497) and only one searcher is opened, warmed, and registered.

        Mark Miller added a comment -

        The commit should not need to open a new searcher - I'll change this.

        Mark Miller added a comment -

        Fix committed.

        Commit Tag Bot added a comment -

        [branch_4x commit] Mark Robert Miller
        http://svn.apache.org/viewvc?view=revision&revision=1385146

        SOLR-3465: Replication causes two searcher warmups.

        Commit Tag Bot added a comment -

        [branch_4x commit] Mark Robert Miller
        http://svn.apache.org/viewvc?view=revision&revision=1385146

        SOLR-3465: Replication causes two searcher warmups.

        Uwe Schindler added a comment -

        Closed after release.


          People

          • Assignee:
            Mark Miller
            Reporter:
            Michael Garski
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development