Solr
  1. Solr
  2. SOLR-3433

binary field returns differently when do the distribute search

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 3.5, 3.6, 4.0-ALPHA
    • Fix Version/s: None
    • Component/s: search
    • Labels:
      None
    • Environment:

      linux, amazon ec2

      Description

      When install multiple nodes (more than one node), the repeated searches through solr returns binary data back differently each time.

      <lst name="responseHeader"><int name="status">0</int><int name="QTime">26</int><lst name="params"><str name="q">text_col:woodman</str></lst></lst><result name="response" numFound="1" start="0" maxScore="0.13258252"><doc><str name="binary_col">[B:[B@714fef9f</str>

      <lst name="responseHeader"><int name="status">0</int><int name="QTime">11</int><lst name="params"><str name="q">text_col:woodman</str></lst></lst><result name="response" numFound="1" start="0" maxScore="0.13258252"><doc><str name="binary_col">[B:[B@4be22114</str><

      check this link, some one report the same issue. http://grokbase.com/t/lucene/solr-user/11beyhmxjw/distributed-search-and-binary-fields-w-solr-3-4

      it works for a single node, but fails for multiple node. it's something related to distributed search

        Activity

        Alex Liu created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Alex Liu
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:

              Development