Solr
  1. Solr
  2. SOLR-3433

binary field returns differently when do the distribute search

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 3.5, 3.6, 4.0-ALPHA
    • Fix Version/s: None
    • Component/s: search
    • Labels:
      None
    • Environment:

      linux, amazon ec2

      Description

      When install multiple nodes (more than one node), the repeated searches through solr returns binary data back differently each time.

      <lst name="responseHeader"><int name="status">0</int><int name="QTime">26</int><lst name="params"><str name="q">text_col:woodman</str></lst></lst><result name="response" numFound="1" start="0" maxScore="0.13258252"><doc><str name="binary_col">[B:[B@714fef9f</str>

      <lst name="responseHeader"><int name="status">0</int><int name="QTime">11</int><lst name="params"><str name="q">text_col:woodman</str></lst></lst><result name="response" numFound="1" start="0" maxScore="0.13258252"><doc><str name="binary_col">[B:[B@4be22114</str><

      check this link, some one report the same issue. http://grokbase.com/t/lucene/solr-user/11beyhmxjw/distributed-search-and-binary-fields-w-solr-3-4

      it works for a single node, but fails for multiple node. it's something related to distributed search

        Activity

        Alex Liu created issue -
        Hide
        Sami Siren added a comment -

        It seems this has been fixed in trunk: SOLR-3035. Alex, can you please give me some more details on how you tested this and what versions, especially did you see this still happen in trunk.

        Show
        Sami Siren added a comment - It seems this has been fixed in trunk: SOLR-3035 . Alex, can you please give me some more details on how you tested this and what versions, especially did you see this still happen in trunk.
        Hide
        Alex Liu added a comment -

        Sami, I think SOLR-3035 fixed the issue for a single node. This ticket is only for multiple node. To reproduce it, you can set up a three nodes cluster, and upload solrconfig.xml, schema.xml with binary fields and some testing data, then you can search on any node.

        Show
        Alex Liu added a comment - Sami, I think SOLR-3035 fixed the issue for a single node. This ticket is only for multiple node. To reproduce it, you can set up a three nodes cluster, and upload solrconfig.xml, schema.xml with binary fields and some testing data, then you can search on any node.
        Hide
        Sami Siren added a comment -

        From what I understand from SOLR-3035 it was not about single node. I also did some tests with multiple shards and did not see this problem on trunk. Perhaps I am missing something important. Could you provide a test case that demonstrates the problem on trunk?

        Show
        Sami Siren added a comment - From what I understand from SOLR-3035 it was not about single node. I also did some tests with multiple shards and did not see this problem on trunk. Perhaps I am missing something important. Could you provide a test case that demonstrates the problem on trunk?

          People

          • Assignee:
            Unassigned
            Reporter:
            Alex Liu
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:

              Development