Solr
  1. Solr
  2. SOLR-3427

Faceting under some conditions throws NPE

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: 4.0-ALPHA
    • Labels:
      None

      Description

      Under some circumstances faceting in Solr throws the following NPE

      May 1, 2012 8:48:52 PM org.apache.solr.common.SolrException log
      SEVERE: java.lang.NullPointerException
      at org.apache.lucene.index.DocTermOrds.lookupTerm(DocTermOrds.java:807)
      at org.apache.solr.request.UnInvertedField.getTermValue(UnInvertedField.java:636)
      at org.apache.solr.request.UnInvertedField.getCounts(UnInvertedField.java:411)
      at org.apache.solr.request.SimpleFacets.getTermCounts(SimpleFacets.java:300)
      at org.apache.solr.request.SimpleFacets.getFacetFieldCounts(SimpleFacets.java:396)
      at org.apache.solr.request.SimpleFacets.getFacetCounts(SimpleFacets.java:205)
      at org.apache.solr.handler.component.FacetComponent.process(FacetComponent.java:81)
      at org.apache.solr.handler.component.SearchHandler.handleRequestBody(SearchHandler.java:204)
      at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:129)
      at org.apache.solr.core.SolrCore.execute(SolrCore.java:1550)
      at org.apache.solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.java:442)
      at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:263)
      at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1337)
      at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:484)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
      at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:524)
      at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:233)
      at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1065)
      at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:413)
      at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:192)
      at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:999)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
      at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:250)
      at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149)
      at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)
      at org.eclipse.jetty.server.Server.handle(Server.java:351)
      at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:454)
      at org.eclipse.jetty.server.BlockingHttpConnection.handleRequest(BlockingHttpConnection.java:47)
      at org.eclipse.jetty.server.AbstractHttpConnection.content(AbstractHttpConnection.java:900)
      at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:954)
      at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:857)
      at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)
      at org.eclipse.jetty.server.BlockingHttpConnection.handle(BlockingHttpConnection.java:66)
      at org.eclipse.jetty.server.bio.SocketConnector$ConnectorEndPoint.run(SocketConnector.java:254)
      at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:599)
      at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:534)
      at java.lang.Thread.run(Thread.java:662)

      I've noticed this happening after doing deletes. When I've seen this issue before an optimize has made the issue go away. I believe this may also be related to the describe here:
      http://stackoverflow.com/questions/10124055/solr-faceted-search-throws-nullpointerexception-with-http-500-status

      I have been unable to reproduce this in a test but this has come up at least 3 times in our environments.

        Issue Links

          Activity

          Jamie Johnson added a comment -

          Thanks Yonik! I will pull the nightly build tomorrow morning to try this out on our environment, appreciate all the help!

          Yonik Seeley added a comment -

          Committed.
          Thanks for the pointers that led to this being solved!

          Yonik Seeley added a comment -

          I've confirmed that LUCENE-3003 is the culprit again. This bug does therefore not affect any previously released Solr version (i.e. 3x or earlier).

          I'll commit a fix soon.

          Jamie Johnson added a comment -

          Great to hear Yonik, sorry I couldn't have given you a working example of the issue, but glad you were able to duplicate it. Please let me know if there is anything else I can provide.

          Yonik Seeley added a comment -

          OK, I've reproduced it... should hopefully have a fix soon.

          Jamie Johnson added a comment -

          I believe the issue is happening on a multivalued field where the document which contributed that field has been deleted. If I can narrow it down to the field that is causing the issue in my index what information can I provide to you that would give you more insight into what is happening?

          Yonik Seeley added a comment -

          I've been working on better random facet testing to try and reproduce this, but have not been able to so far.

          Any pointers for how to replicate this would be appreciated.


            People

            • Assignee:
              Unassigned
              Reporter:
              Jamie Johnson
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development