Solr
  1. Solr
  2. SOLR-340

SolrSharp - Paging not working properly for rows greater than 10.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.2
    • Component/s: clients - C#
    • Labels:
      None
    • Environment:

      .NET

      Description

      The paging is not working properly when using rows greater than 10.
      Reproduce:
      1. Set rows = 100
      2. Go to second page and you will see duplicates of page 1.

        Activity

        Mike Moser added a comment -

        This file has the fix in it on line 337. I made a call to GetStartFromPage() which was I believe the creator intended to do. It was previously assuming that the number of rows would always be 10.

        Mike Moser added a comment -

        Fixed this with the attached QueryBuilder.cs.

        Jeff Rodenburg added a comment -

        Thanks Mike. This fix has been added to the committed code in svn (http://solrstuff.org/svn/solrsharp).


          People

          • Assignee:
            Jeff Rodenburg
            Reporter:
            Mike Moser
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development