Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      an update followed by a commit will still trigger an autocommit later.

      1. SOLR-3391.patch
        3 kB
        Yonik Seeley
      2. SOLR-3391.patch
        2 kB
        Yonik Seeley

        Activity

        Yonik Seeley added a comment -

        You can see this by executing the following update command, and observing another commit 15 seconds later (caused by autocommit)

        curl http://localhost:8983/solr/update/json?commit=true -H 'Content-type:application/json' -d '[{"id":"2", "foo_t":"x y"}]'
        
        Yonik Seeley added a comment -

        Well.... this would explain it

          /** Inform tracker that a commit has occurred */
          public void didCommit() {
          }
        
        Yonik Seeley added a comment -

        Here's a patch that seems to work. It currently causes a test failure though - I imagine I just need to adjust the expectations of the test.

        Yonik Seeley added a comment -

        New patch with test fixed.


          People

          • Assignee:
            Unassigned
            Reporter:
            Yonik Seeley
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development