Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0-ALPHA, 5.0
    • Component/s: query parsers
    • Labels:
      None

      Description

      Add support for custom Phrase Slop for "pf2" and "pf3" of edismax. If not specified, it should use "ps" as today.

      1. SOLR-3351.patch
        8 kB
        Jan Høydahl

        Issue Links

          Activity

          Jan Høydahl added a comment -
          Jan Høydahl added a comment -

          Preparing for commit...

          Jan Høydahl added a comment -

          Patch adding ps2 and ps3 params, including test cases

          Yonik Seeley added a comment - - edited

          There was a proposal (and an issue) to fold the slop into the phrase field specification:
          pf=text~3 would create phrase queries with a slop of 3

          This allows different slops for different fields, keeps the number of parameters down, and is more understandable.

          edit: the issue is SOLR-2058


            People

            • Assignee:
              Jan Høydahl
              Reporter:
              Jan Høydahl
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development