The presence of 'qt' on this page bothers me just a little.
Yes, i realized this already ;> I don't mind if we change it!
What about the following: In preparation of changing the Handler-Selection, we move the current qt-Field to the top, over the "common"-Section and we name it "Request-Handler (qt)". That the used parameter (if needed) is named qt does not even matter, but w/o the "(qt)" addition i can already hear some "where is the qt-option questions" *gg
JFYI: For the upcoming selection, i'd like to use Chosen (which is already in place for the Schema-Browser and the Analysis) - useful especially for those who have defined more than a few Handlers in their Instance.