Solr
  1. Solr
  2. SOLR-3283

PingRequestHandler should have qt be optional

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.6, 4.0-ALPHA
    • Component/s: None
    • Labels:
      None

      Description

      PingRequestHandler insists that "qt" be specified for its query. I think it should be optional since the default request handler can be looked up via null. QuerySenderListener doesn't mandate qt for the same reason.

        Activity

        David Smiley added a comment -

        Attached is a patch making it optional. It didn't seem worth a CHANGES.txt entry.

        By the way, this issue is slightly related to my observation and comment with patch here: https://issues.apache.org/jira/browse/SOLR-3161?focusedCommentId=13239186&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13239186

        Can this be committed to 3x tonight for inclusion in 3.6? I ask because it's kinda late.

        David Smiley added a comment -

        I'll commit this minor improvement ~tonight EST.

        David Smiley added a comment -

        Committed to 3x & 4x

        Mark Miller added a comment -

        Reverted on 4x

        Mark Miller added a comment -

        It didn't seem worth a CHANGES.txt entry.

        I think even small improvements should probably have a CHANGES entry.

        Didn't revert due to that though - the 3 other commits done around this one caused many test failures.

        David Smiley added a comment -

        I re-committed this on March 29th. This wasn't the cause of the test failure. Marking as resolved.


          People

          • Assignee:
            David Smiley
            Reporter:
            David Smiley
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 20m
              20m
              Remaining:
              Remaining Estimate - 20m
              20m
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development