Solr
  1. Solr
  2. SOLR-3263

Stop including more than one servlet-api jar version in the test classpath in the Maven build

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: 4.0-ALPHA
    • Component/s: Build
    • Labels:
      None

      Description

      Today's nightly Jenkins Maven trunk build has several test failures with the error message:

      class "javax.servlet.FilterRegistration"'s signer information does not match signer information of other classes in the same package
      

      On SOLR-3260, Ryan McKinley mentioned that these errors can be caused by mixing servlet-api jar versions.

        Activity

        Ryan McKinley added a comment -

        thanks Steven!

        Steve Rowe added a comment -

        The errors are no longer occurring on the trunk Jenkins Maven job.

        Steve Rowe added a comment -

        I committed to trunk.

        I'll go kick off a trunk Maven build on Jenkins now.

        Steve Rowe added a comment - - edited

        Patch switching the solr-core module's servlet-api dependency from "compile" to "provided" scope. This causes it to not be placed on the runtime classpath.

        This change makes most Solr contrib modules' tests fail because of missing classes contained in the servlet-api jar. For those modules with failing tests, I added a servlet-api test dependency.

        All trunk Solr tests pass for me locally under Maven.

        Committing shortly.


          People

          • Assignee:
            Steve Rowe
            Reporter:
            Steve Rowe
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development