Solr
  1. Solr
  2. SOLR-3206

testRecoveryMultipleLogs(org.apache.solr.search.TestRecovery)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0-ALPHA
    • Component/s: None

      Description

      Failure on the build server. Looks like a number parsing problem but I cannot reproduce with the same seed.

      build	06-Mar-2012 08:11:20	    [junit] Testcase: testRecoveryMultipleLogs(org.apache.solr.search.TestRecovery):	Caused an ERROR
      build	06-Mar-2012 08:11:20	    [junit] org.apache.solr.common.SolrException
      build	06-Mar-2012 08:11:20	    [junit] java.lang.RuntimeException: org.apache.solr.common.SolrException
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.util.TestHarness.<init>(TestHarness.java:152)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.util.TestHarness.<init>(TestHarness.java:135)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.util.TestHarness.<init>(TestHarness.java:125)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.SolrTestCaseJ4.createCore(SolrTestCaseJ4.java:351)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.search.TestRecovery.testRecoveryMultipleLogs(TestRecovery.java:797)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.lucene.util.SystemPropertiesRestoreRule$1.evaluate(SystemPropertiesRestoreRule.java:20)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.lucene.util.LuceneTestCase$SubclassSetupTeardownRule$1.evaluate(LuceneTestCase.java:736)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.lucene.util.LuceneTestCase$InternalSetupTeardownRule$1.evaluate(LuceneTestCase.java:632)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.lucene.util.SystemPropertiesInvariantRule$1.evaluate(SystemPropertiesInvariantRule.java:22)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.lucene.util.LuceneTestCase$TestResultInterceptorRule$1.evaluate(LuceneTestCase.java:531)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.lucene.util.LuceneTestCase$RememberThreadRule$1.evaluate(LuceneTestCase.java:593)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.lucene.util.LuceneTestCaseRunner.runChild(LuceneTestCaseRunner.java:165)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.lucene.util.LuceneTestCaseRunner.runChild(LuceneTestCaseRunner.java:57)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.lucene.util.SystemPropertiesRestoreRule$1.evaluate(SystemPropertiesRestoreRule.java:20)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.lucene.util.SystemPropertiesInvariantRule$1.evaluate(SystemPropertiesInvariantRule.java:22)
      build	06-Mar-2012 08:11:20	    [junit] Caused by: org.apache.solr.common.SolrException
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.core.SolrCore.<init>(SolrCore.java:614)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.core.SolrCore.<init>(SolrCore.java:498)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.util.TestHarness$Initializer.initialize(TestHarness.java:216)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.util.TestHarness.<init>(TestHarness.java:140)
      build	06-Mar-2012 08:11:20	    [junit] Caused by: org.apache.solr.common.SolrException: Error Instantiating Update Handler, solr.DirectUpdateHandler2 failed to instantiate org.apache.solr.update.UpdateHandler
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.core.SolrCore.createInstance(SolrCore.java:425)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.core.SolrCore.createUpdateHandler(SolrCore.java:475)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.core.SolrCore.<init>(SolrCore.java:598)
      build	06-Mar-2012 08:11:20	    [junit] Caused by: java.lang.reflect.InvocationTargetException
      build	06-Mar-2012 08:11:20	    [junit] 	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.core.SolrCore.createInstance(SolrCore.java:418)
      build	06-Mar-2012 08:11:20	    [junit] Caused by: java.lang.NumberFormatException: For input string: "000000000000000001:"
      build	06-Mar-2012 08:11:20	    [junit] 	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
      build	06-Mar-2012 08:11:20	    [junit] 	at java.lang.Long.parseLong(Long.java:419)
      build	06-Mar-2012 08:11:20	    [junit] 	at java.lang.Long.parseLong(Long.java:468)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.update.UpdateLog.getLastLogId(UpdateLog.java:264)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.update.UpdateLog.init(UpdateLog.java:164)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.update.UpdateHandler.initLog(UpdateHandler.java:94)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.update.UpdateHandler.<init>(UpdateHandler.java:123)
      build	06-Mar-2012 08:11:20	    [junit] 	at org.apache.solr.update.DirectUpdateHandler2.<init>(DirectUpdateHandler2.java:95)
      

      After that lots of other exceptions. It might have been a suite dependency or left-over so I will attach a full log too.

      1. error.log
        602 kB
        Dawid Weiss
      2. output.log
        571 kB
        Dawid Weiss

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1d 3h 12m 1 Dawid Weiss 07/Mar/12 10:54
        Resolved Resolved Closed Closed
        428d 23h 45m 1 Uwe Schindler 10/May/13 11:40
        Uwe Schindler made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Dawid Weiss made changes -
        Assignee Dawid Weiss [ dweiss ]
        Dawid Weiss made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Dawid Weiss added a comment -

        It's a problem in the test – it attempts to generate a log name and overflows on the last digit from '9' to ':'.

        Dawid Weiss made changes -
        Labels cannot-reproduce seed-doesnt-reproduce
        Dawid Weiss made changes -
        Attachment output.log [ 12517226 ]
        Dawid Weiss added a comment -

        Another run, the same error (different seed, but still not reproducible).

        May be useful for checking the suite order.

        Dawid Weiss made changes -
        Field Original Value New Value
        Attachment error.log [ 12517202 ]
        Dawid Weiss added a comment -

        Full build log.

        Dawid Weiss created issue -

          People

          • Assignee:
            Dawid Weiss
            Reporter:
            Dawid Weiss
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development