Solr
  1. Solr
  2. SOLR-3188

New admin page: "Enable Polling" button disappears after disabling polling and reloading page

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Invalid
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: None
    • Component/s: web gui
    • Labels:

      Description

      When you go to this URL on a slave:
      http://localhost:8983/solr/#/singlecore/replication

      And click the "Disable Polling" button, you see a red bar that says "invalid_master". I'm not sure why I get this red bar, as I haven't tested it outside of my own installation, but it seems normal.

      If you then refresh the page, the "Replicate Now" and "Enable Polling" buttons disappear. It seems like their generation is being interrupted by the "invalid_master" error.

        Issue Links

          Activity

          Neil Hooey created issue -
          Neil Hooey made changes -
          Field Original Value New Value
          Link This issue blocks SOLR-3162 [ SOLR-3162 ]
          Ryan McKinley made changes -
          Component/s web gui [ 12310675 ]
          Component/s Schema and Analysis [ 12312520 ]
          Stefan Matheis (steffkes) made changes -
          Assignee Stefan Matheis (steffkes) [ steffkes ]
          Stefan Matheis (steffkes) made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Invalid [ 6 ]
          Gavin made changes -
          Link This issue blocks SOLR-3162 [ SOLR-3162 ]
          Gavin made changes -
          Link This issue is depended upon by SOLR-3162 [ SOLR-3162 ]

            People

            • Assignee:
              Stefan Matheis (steffkes)
              Reporter:
              Neil Hooey
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development