Solr
  1. Solr
  2. SOLR-2905

CoreAdminHandler STATUS should display name of default core

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 3.4
    • Fix Version/s: None
    • Component/s: multicore
    • Labels:
      None

      Description

      STATUS action returns empty name for default core.

      solr.xml:

        <cores adminPath="/admin/cores" defaultCoreName="core1">
          <core name="core1" instanceDir="." />
      	<core name="core2" instanceDir="." />
        </cores>
      

      http://localhost:8983/solr/admin/cores?action=STATUS returns

      <response>
          ...
          <lst name="status">
              <lst name=""> <!-- name is empty here -->
                  <str name="name"/> <!-- name is empty here -->
                  <str name="instanceDir">solr\.\</str>
                  <str name="dataDir">solr\.\data\</str>
                  ...
              </lst>
              <lst name="core2">
                  <str name="name">core2</str>
                  <str name="instanceDir">solr\.\</str>
                  <str name="dataDir">solr\.\data\</str>
                  ...
              </lst>
          </lst>
      </response>
      

      but everything works as expected if remove

        defaultCoreName="core1"
      

      from solr.xml

        Issue Links

          Activity

          Ivan Hrytsyuk added a comment -

          Indeed - it duplicates SOLR-2605

          Stefan Matheis (steffkes) added a comment -

          Hey Ivan, looks like a duplicate of SOLR-2605, no? Regards Stefan


            People

            • Assignee:
              Unassigned
              Reporter:
              Ivan Hrytsyuk
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development