Solr
  1. Solr
  2. SOLR-2836

maven compilation error - symbol not found - ShardFieldSortedHitQueue

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: None
    • Component/s: Build
    • Labels:

      Description

      maven building fails at several point due to organization of tests however even when you bypass test compilation, you get "symbol not found" error in QueryComponent.java.

      The reason is that the ShardFieldSortedHitQueue is a class defined in ShardDoc.

      class cannot be found during maven compilation although they're under the same package.

      Workaroud: if you promote ShardFieldSortedHitQueue to be public, and put it in a file of its own, maven compilation goes well.

      There seems to be several boundary problems within core and solrj packages about the tests.

        Activity

        Ukyo Virgden added a comment -

        Steven, It's been a while since I've checked, I'll give it a try again, thanks.

        Steve Rowe added a comment -

        See my comments on SOLR-2835, which is symptomatic of the same problem(s) underlying this issue.

        Ukyo Virgden added a comment -

        steps to reproduce

        • svn update
        • ant get-maven-poms
        • mvn -N -Pbootstrap install
        • mvn install -Dmaven.test.skip=true

          People

          • Assignee:
            Steve Rowe
            Reporter:
            Ukyo Virgden
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development