Solr
  1. Solr
  2. SOLR-2421

Remove solr/lib/geronimo-stax-api_1.0_spec-1.0.1.jar - Stax API 1.0 is included in JAXP 1.4, which is included in Java 1.6

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: 4.0-ALPHA
    • Component/s: Build
    • Labels:
      None

      Description

      Uwe wrote on #lucene IRC:

      stax api 1.0 is also included in xmlapis for jaxp 1.4
      in solr 3.x the geromino stuff is needed
      because its java 5 only and java 5 has no javax.xml.stream stuff
      this geronimo blabla file is just containing those abstrcat interfaces and factory classes
      for trunk its included in java 6
      

        Issue Links

          Activity

          Uwe Schindler made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Steve Rowe made changes -
          Link This issue relates to SOLR-2756 [ SOLR-2756 ]
          Steve Rowe made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Assignee Steven Rowe [ steve_rowe ]
          Resolution Fixed [ 1 ]
          Steve Rowe made changes -
          Field Original Value New Value
          Attachment SOLR-2421.patch [ 12479947 ]
          Steve Rowe created issue -

            People

            • Assignee:
              Steve Rowe
              Reporter:
              Steve Rowe
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development