Solr
  1. Solr
  2. SOLR-2161

BasicDistributedZkTest.testDistribSearch test failure

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: 4.0-ALPHA
    • Component/s: Build
    • Labels:
      None
    • Environment:

      Hudson

      Description

      BasicDistributedZkTest.testDistribSearch failed in Hudson.

      Here is the stacktrace:

          [junit] Testsuite: org.apache.solr.cloud.BasicDistributedZkTest
          [junit] Testcase: testDistribSearch(org.apache.solr.cloud.BasicDistributedZkTest):	Caused an ERROR
          [junit] Error executing query
          [junit] org.apache.solr.client.solrj.SolrServerException: Error executing query
          [junit] 	at org.apache.solr.client.solrj.request.QueryRequest.process(QueryRequest.java:95)
          [junit] 	at org.apache.solr.client.solrj.SolrServer.query(SolrServer.java:119)
          [junit] 	at org.apache.solr.BaseDistributedSearchTestCase.queryServer(BaseDistributedSearchTestCase.java:290)
          [junit] 	at org.apache.solr.cloud.BasicDistributedZkTest.queryServer(BasicDistributedZkTest.java:256)
          [junit] 	at org.apache.solr.BaseDistributedSearchTestCase.query(BaseDistributedSearchTestCase.java:305)
          [junit] 	at org.apache.solr.cloud.BasicDistributedZkTest.doTest(BasicDistributedZkTest.java:227)
          [junit] 	at org.apache.solr.BaseDistributedSearchTestCase.testDistribSearch(BaseDistributedSearchTestCase.java:562)
          [junit] 	at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:795)
          [junit] 	at org.apache.lucene.util.LuceneTestCase$LuceneTestCaseRunner.runChild(LuceneTestCase.java:768)
          [junit] Caused by: org.apache.solr.common.SolrException: org.apache.solr.client.solrj.SolrServerException: org.apache.commons.httpclient.NoHttpResponseException: The server 127.0.0.1 failed to respond  org.apache.solr.common.SolrException: org.apache.solr.client.solrj.SolrServerException: org.apache.commons.httpclient.NoHttpResponseException: The server 127.0.0.1 failed to respond 	at org.apache.solr.handler.component.SearchHandler.handleRequestBody(SearchHandler.java:318) 	at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:131) 	at org.apache.solr.core.SolrCore.execute(SolrCore.java:1325) 	at org.apache.solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.java:337) 	at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:240) 	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157) 	at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:388) 	at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182) 	at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:765) 	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152) 	at org.mortbay.jetty.Server.handle(Server.java:326) 	at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542) 	at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:923) 	at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:547) 	at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212) 	at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404) 	at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:409) 	at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582) Caused by: org.apache.solr.client.solrj.SolrServerException: org.apache.commons.httpclient.NoHttpResponseException: The server 127.0.0.1 failed to respond 	at org.apache.solr.client.solrj.impl.CommonsHttpSolrServer.request(CommonsHttpSolrServer.java:483) 	at org.apache.solr.client.solrj.impl.CommonsHttpSolrServer.reque
          [junit] 
          [junit] org.apache.solr.client.solrj.SolrServerException: org.apache.commons.httpclient.NoHttpResponseException: The server 127.0.0.1 failed to respond  org.apache.solr.common.SolrException: org.apache.solr.client.solrj.SolrServerException: org.apache.commons.httpclient.NoHttpResponseException: The server 127.0.0.1 failed to respond 	at org.apache.solr.handler.component.SearchHandler.handleRequestBody(SearchHandler.java:318) 	at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:131) 	at org.apache.solr.core.SolrCore.execute(SolrCore.java:1325) 	at org.apache.solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.java:337) 	at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:240) 	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157) 	at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:388) 	at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182) 	at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:765) 	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152) 	at org.mortbay.jetty.Server.handle(Server.java:326) 	at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542) 	at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:923) 	at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:547) 	at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212) 	at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404) 	at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:409) 	at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582) Caused by: org.apache.solr.client.solrj.SolrServerException: org.apache.commons.httpclient.NoHttpResponseException: The server 127.0.0.1 failed to respond 	at org.apache.solr.client.solrj.impl.CommonsHttpSolrServer.request(CommonsHttpSolrServer.java:483) 	at org.apache.solr.client.solrj.impl.CommonsHttpSolrServer.reque
          [junit] 
          [junit] request: http://localhost:57159/solr/select?q=*:*&rows=100&shards=shard3,shard4,shard5,shard6&distrib=true&wt=javabin&version=2
          [junit] 	at org.apache.solr.client.solrj.impl.CommonsHttpSolrServer.request(CommonsHttpSolrServer.java:435)
          [junit] 	at org.apache.solr.client.solrj.impl.CommonsHttpSolrServer.request(CommonsHttpSolrServer.java:244)
          [junit] 	at org.apache.solr.client.solrj.request.QueryRequest.process(QueryRequest.java:89)
          [junit] 
          [junit] 
          [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 249.281 sec
          [junit] 
          [junit] ------------- Standard Output ---------------
          [junit] NOTE: reproduce with: ant test -Dtestcase=BasicDistributedZkTest -Dtestmethod=testDistribSearch -Dtests.seed=7581155515203828654:-2786059863405912356
          [junit] NOTE: test params are: codec=MockSep, locale=es_GT, timezone=America/Shiprock
          [junit] ------------- ---------------- ---------------
          [junit] ------------- Standard Error -----------------
          [junit] 14/10/2010 02:48:15 PM org.apache.solr.common.SolrException log
          [junit] GRAVE: org.apache.solr.common.SolrException: org.apache.solr.client.solrj.SolrServerException: org.apache.commons.httpclient.NoHttpResponseException: The server 127.0.0.1 failed to respond
          [junit] 	at org.apache.solr.handler.component.SearchHandler.handleRequestBody(SearchHandler.java:318)
          [junit] 	at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:131)
          [junit] 	at org.apache.solr.core.SolrCore.execute(SolrCore.java:1325)
          [junit] 	at org.apache.solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.java:337)
          [junit] 	at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:240)
          [junit] 	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)
          [junit] 	at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:388)
          [junit] 	at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
          [junit] 	at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:765)
          [junit] 	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
          [junit] 	at org.mortbay.jetty.Server.handle(Server.java:326)
          [junit] 	at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)
          [junit] 	at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:923)
          [junit] 	at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:547)
          [junit] 	at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212)
          [junit] 	at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
          [junit] 	at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:409)
          [junit] 	at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)
          [junit] Caused by: org.apache.solr.client.solrj.SolrServerException: org.apache.commons.httpclient.NoHttpResponseException: The server 127.0.0.1 failed to respond
          [junit] 	at org.apache.solr.client.solrj.impl.CommonsHttpSolrServer.request(CommonsHttpSolrServer.java:483)
          [junit] 	at org.apache.solr.client.solrj.impl.CommonsHttpSolrServer.request(CommonsHttpSolrServer.java:244)
          [junit] 	at org.apache.solr.handler.component.HttpCommComponent$1.call(SearchHandler.java:511)
          [junit] 	at org.apache.solr.handler.component.HttpCommComponent$1.call(SearchHandler.java:478)
          [junit] 	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
          [junit] 	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
          [junit] 	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
          [junit] 	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
          [junit] 	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
          [junit] 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
          [junit] 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
          [junit] 	at java.lang.Thread.run(Thread.java:636)
          [junit] Caused by: org.apache.commons.httpclient.NoHttpResponseException: The server 127.0.0.1 failed to respond
          [junit] 	at org.apache.commons.httpclient.HttpMethodBase.readStatusLine(HttpMethodBase.java:1976)
          [junit] 	at org.apache.commons.httpclient.HttpMethodBase.readResponse(HttpMethodBase.java:1735)
          [junit] 	at org.apache.commons.httpclient.HttpMethodBase.execute(HttpMethodBase.java:1098)
          [junit] 	at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:398)
          [junit] 	at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
          [junit] 	at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
          [junit] 	at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:323)
          [junit] 	at org.apache.solr.client.solrj.impl.CommonsHttpSolrServer.request(CommonsHttpSolrServer.java:427)
          [junit] 	... 11 more
          [junit] 
          [junit] ------------- ---------------- ---------------
          [junit] TEST org.apache.solr.cloud.BasicDistributedZkTest FAILED
      

        Activity

        Dawid Weiss added a comment -

        This test fails very frequently. The most recent failure here:
        https://builds.apache.org/job/Lucene-Solr-tests-only-trunk-java7/2235/

        I am putting it in a @AwaitsFix group.

        Saurabh added a comment -

        We are also seeing same exception randomly, any leads?

        Yonik Seeley added a comment -

        I checked in some changes that should fix the most common failures we were seeing due to the recovery threads not being stopped.

        Dawid Weiss added a comment -

        Thanks Yonik!


          People

          • Assignee:
            Unassigned
            Reporter:
            Robert Muir
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development