Solr
  1. Solr
  2. SOLR-1864

Master/Slave replication causes tomcat to be unresponsive on slave till replication is being done.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.5
    • Fix Version/s: None
    • Component/s: replication (java)
    • Labels:
      None
    • Environment:

      Centos 5.2, Tomcat5, java version "1.6.0"
      OpenJDK Runtime Environment (build 1.6.0-b09)
      OpenJDK 64-Bit Server VM (build 1.6.0-b09, mixed mode)

      Description

      Hi guys,

      I have found a strange behaviour on tomcat5, centos 5.2.
      While replication is being done (> million rows) tomcat5 seems to be unresponsive till its finished.

      Please help

      cheers,
      /Marcin

        Issue Links

          Activity

          Marcin created issue -
          Peter Karich added a comment -

          This might be a duplicate of: https://issues.apache.org/jira/browse/SOLR-1775

          The reason might be (as Paul Noble noted) that the garbage collector is busy a lot because of autowarm up after index switch was done

          Peter Karich made changes -
          Field Original Value New Value
          Link This issue duplicates SOLR-1775 [ SOLR-1775 ]
          Peter Karich added a comment -

          as the description is rare I think, this could be a duplicate of 1775

          Jan Høydahl added a comment -

          Closing as duplicate.
          If you believe this is not correct, please re-open and provide more information on the issue.

          Jan Høydahl made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Duplicate [ 3 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          1960d 16h 54m 1 Jan Høydahl 18/Aug/15 09:06

            People

            • Assignee:
              Unassigned
              Reporter:
              Marcin
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development