Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-16206

bats 1.7.0 spews warnings about minimum version

    XMLWordPrintableJSON

Details

    • Test
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 9.1, main (10.0), 9.0.1
    • None
    • None

    Description

      bats 1.7.0 was released a week ago https://github.com/bats-core/bats-core/releases/tag/v1.7.0 and added a new warning:

      BW02: Using flags on `run` requires at least BATS_VERSION=1.5.0. Use `bats_require_minimum_version 1.5.0` to fix this message.
            (from function `bats_warn_minimum_guaranteed_version' in file /Users/mdrob/code/solr/.gradle/node/packaging/node_modules/bats/lib/bats-core/warnings.bash, line 31,
             from function `run' in file /Users/mdrob/code/solr/.gradle/node/packaging/node_modules/bats/lib/bats-core/test_functions.bash, line 238,
             in test file test/test_create_collection.bats, line 89)
      

      Attachments

        Activity

          People

            mdrob Mike Drob
            mdrob Mike Drob
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: