Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-14900

Update ReGuide build's asciidoctor and ruby/jruby modules to the latest version

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: documentation
    • Labels:
      None

      Description

      Reference Guide build process was using old versions of the libraries due to various issues related to ant, PDF and possible overlapping bugs.

      This is starting to generate errors during first-build. It is worth seeing if the upgrade can be done cleanly as well after other cleanups already done.

      Warnings:

      Sass issue

      Ruby Sass has reached end-of-life and should no longer be used.

      • If you use Sass as a command-line tool, we recommend using Dart Sass, the new
      Options issue

      Deprecation: The 'gems' configuration option has been renamed to 'plugins'. Please update your config file accordingly.

        Attachments

          Activity

            People

            • Assignee:
              arafalov Alexandre Rafalovitch
              Reporter:
              arafalov Alexandre Rafalovitch

              Dates

              • Created:
                Updated:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 3h 50m
                3h 50m

                  Issue deployment