Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-14676

Update commons-collections to 4.4 and use it in Solr

    XMLWordPrintableJSON

    Details

    • Type: Wish
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 8.6
    • Fix Version/s: 8.7
    • Component/s: clients - java
    • Labels:
      None

      Description

      solr-test-framework has dependency to commons-collections:commons-collections
      which moved to org.apache.commons:commons-collections4 some years ago.
      It would be nice to replace or remove this old dependency.

      NOTE: Hadoop requires 3.2.2 so we need it. That said, we've already upgraded commons-collections to 4.2 but Solr code still uses 3.2.2. This ticket will upgrade to 4.4 and eliminate Solr's use of 3.2.2. We still need 3.2.2 as well due to Hadoop.

        Attachments

          Activity

            People

            • Assignee:
              erickerickson Erick Erickson
              Reporter:
              bwahlen Bernd Wahlen
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: