Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-14513

can not compile with jdk1.8.0_20

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 8.5.1
    • Fix Version/s: None
    • Component/s: Build
    • Labels:
      None

      Description

      while use jdk1.8.0_20 to compile by following command:

      ant compile

       

      the process is abort by compile error while compile the file:

      solr-8.5.1\lucene\queries\src\java\org\apache\lucene\queries\intervals\ConjunctionDISI.java

      at line 68:

       
      64  private ConjunctionDISI(List<? extends DocIdSetIterator> iterators) {
      65    assert iterators.size() >= 2;
      66    // Sort the array the first time to allow the least frequent DocsEnum to
      67    // lead the matching.
      68    CollectionUtil.timSort(iterators, Comparator.comparingLong(DocIdSetIterator::cost));
      69    lead1 = iterators.get(0);
      70    lead2 = iterators.get(1);
      71    others = iterators.subList(2, iterators.size()).toArray(new DocIdSetIterator[0]);
      72  }
       

       

      and then, i setup the JDK 13, compile is success:

      ant compile

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              qq2913386086 aiqunfang
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: