Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-12818

failed create collection leaves dirty state

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 7.5
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I tried creating a collection in 7.5 that will always error out:
      1. bin/solr start -e cloud -noprompt
      2. http://localhost:8983/solr/admin/collections?action=CREATE&name=_name_of_collection_1&numShards=1&replicationFactor=3&autoAddReplicas=true

      The create collection failed but the /collections/_name_of_collection_1/state.json get's left behind

      {"_name_of_collection_1":{
          "pullReplicas":"0",
          "replicationFactor":"3",
          "router":{"name":"compositeId"},
          "maxShardsPerNode":"1",
          "autoAddReplicas":"true",
          "nrtReplicas":"3",
          "tlogReplicas":"0",
          "shards":{"shard1":{
              "range":"80000000-7fffffff",
              "state":"active",
              "replicas":{}}}}}

      This doesn't happen in 7.4

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              varun Varun Thacker
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: