Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-11084

Issue with starting script with solr.home (-s) == solr

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 6.6
    • Fix Version/s: 7.1, master (8.0)
    • Component/s: None
    • Security Level: Public (Default Security Level. Issues are Public)
    • Labels:
      None
    • Environment:

      OS X 10.12

      Description

      I've just hit an issue when starting solr using the script. All works well when I use:

      /solr-6.6.0/bin/solr start -p 9090 -m 4g -s data/solr

      However if I cd into the data directory and try:

      /solr-6.6.0/bin/solr start -p 9090 -m 4g -s solr

      Then I get no cores loaded and the "solr.​solr.​home" shown in the UI as my installation solr (i.e. /solr-6.6.0/server/solr)

      I thought that "solr" may be a reserved word so I changed the name of my folder to "test-solr" and this worked.

      I'm unsure if this is an undocumented feature (at least I couldn't find any reference to it) or a bug.

        Attachments

        1. SOLR-11084.patch
          3 kB
          Amrit Sarkar
        2. SOLR-11084.patch
          2 kB
          Neil Ireson

          Activity

            People

            • Assignee:
              erickerickson Erick Erickson
              Reporter:
              neilireson Neil Ireson
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: