ServiceMix NMR
  1. ServiceMix NMR
  2. SMX4NMR-181

JBI itests' ManagementTest intermittently fails on slower CI build machines

    Details

    • Type: Test Test
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.2.0
    • Labels:
      None

      Description

      On slower CI build machines, the JBI itests' ManagementTest intermittently fails. From the log, it looks like it's a pure timing issue - the AdminCommandsService is being registered at almost the exact same moment that the test gives up waiting for it.

      [12:18:56]: [pool-2-thread-3] DEBUG org.apache.geronimo.blueprint.container.ServiceRecipe - Registering service .component-4 with interfaces [org.apache.servicemix.jbi.deployer.AdminCommandsService] and properties {osgi.service.blueprint.compname=adminCommandsService}
      [12:18:56]: [pool-2-thread-3] DEBUG org.apache.geronimo.blueprint.container.ServiceRecipe - Retrieving service for bundle pax-exam-probe_0.0.0 [57] and service registration {org.apache.servicemix.jbi.deployer.AdminCommandsService}={osgi.service.blueprint.compname=adminCommandsService, service.id=80}
      [12:18:56]: [pool-2-thread-3] DEBUG org.apache.geronimo.blueprint.container.ServiceRecipe - Creating service instance
      [12:18:56]: [SpringOsgiExtenderThread-1] DEBUG org.springframework.beans.factory.xml.DefaultNamespaceHandlerResolver - Loaded mappings [{}]
      [12:18:56]: [SpringOsgiExtenderThread-1] DEBUG org.springframework.osgi.extender.internal.support.NamespacePlugins - Trying to resolving namespace handler for http://www.springframework.org/schema/osgi
      [12:18:57]: [SpringOsgiExtenderThread-1] DEBUG org.springframework.beans.factory.xml.DefaultNamespaceHandlerResolver - Loaded mappings [{http://www.springframework.org/schema/lang=org.springframework.scripting.config.LangNamespaceHandler, http://www.springframework.org/schema/jee=org.springframework.ejb.config.JeeNamespaceHandler, http://www.springframework.org/schema/context=org.springframework.context.config.ContextNamespaceHandler}]
      [12:18:57]: [SpringOsgiExtenderThread-1] DEBUG org.springframework.beans.factory.xml.DefaultNamespaceHandlerResolver - Loaded mappings [{http://www.springframework.org/schema/p=org.springframework.beans.factory.xml.SimplePropertyNamespaceHandler, http://www.springframework.org/schema/util=org.springframework.beans.factory.xml.UtilNamespaceHandler}]
      [12:18:58]: [SpringOsgiExtenderThread-1] DEBUG org.springframework.beans.factory.xml.DefaultNamespaceHandlerResolver - Loaded mappings [{http://www.springframework.org/schema/osgi-compendium=org.springframework.osgi.compendium.config.CompendiumNamespaceHandler, http://www.springframework.org/schema/osgi=org.springframework.osgi.config.OsgiNamespaceHandler}]
      [12:18:58]: [pool-2-thread-1] DEBUG org.apache.servicemix.nmr.osgi - ServiceEvent REGISTERED
      [12:18:58]: [pool-2-thread-1] DEBUG org.apache.geronimo.blueprint.container.BlueprintContainerImpl - Instantiating components: [blueprintContainer, blueprintBundle, blueprintBundleContext, blueprintConverter, .component-1, servicemix, .component-2, managementStrategy, flowRegistry, endpointTracker, listenerRegistry, .component-3, endpointRegistry, internalEndpointRegistry, .component-4, wireRegistry, .component-5, authorizationService, .component-6, authorizationEntries, .component-7, authenticationService, .component-8, executorFactory, org.apache.geronimo.managedObjectManager, .cm-4]
      [12:18:58]: [RMI TCP Connection(1)-10.65.4.7] DEBUG sun.rmi.server.call - RMI TCP Connection(1)-10.65.4.7: [10.65.4.7] exception: 
      [12:18:58]: java.lang.reflect.InvocationTargetException
      [12:18:58]: 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [12:18:58]: 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:48)
      [12:18:59]: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      [12:18:59]: 	at java.lang.reflect.Method.invoke(Method.java:600)
      [12:18:59]: 	at org.ops4j.pax.exam.rbc.internal.RemoteBundleContextImpl.remoteCall(RemoteBundleContextImpl.java:80)
      [12:18:59]: 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [12:18:59]: 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:48)
      [12:18:59]: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      [12:18:59]: 	at java.lang.reflect.Method.invoke(Method.java:600)
      [12:18:59]: 	at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:310)
      [12:18:59]: 	at sun.rmi.transport.Transport$1.run(Transport.java:171)
      [12:18:59]: 	at java.security.AccessController.doPrivileged(AccessController.java:284)
      [12:18:59]: 	at sun.rmi.transport.Transport.serviceCall(Transport.java:167)
      [12:18:59]: 	at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:547)
      [12:18:59]: 	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:802)
      [12:18:59]: 	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:661)
      [12:19:00]: 	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      [12:19:00]: 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      [12:19:00]: 	at java.lang.Thread.run(Thread.java:736)
      [12:19:00]: Caused by: java.lang.reflect.InvocationTargetException
      [12:19:00]: 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [12:19:00]: 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:48)
      [12:19:00]: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      [12:19:00]: 	at java.lang.reflect.Method.invoke(Method.java:600)
      [12:19:00]: 	at org.ops4j.pax.exam.junit.extender.impl.internal.CallableTestMethodImpl.injectContextAndInvoke(CallableTestMethodImpl.java:134)
      [12:19:00]: 	at org.ops4j.pax.exam.junit.extender.impl.internal.CallableTestMethodImpl.call(CallableTestMethodImpl.java:101)
      [12:19:00]: 	... 19 more
      [12:19:00]: Caused by: java.lang.RuntimeException: Gave up waiting for service (objectClass=org.apache.servicemix.jbi.deployer.AdminCommandsService)
      [12:19:01]: 	at org.apache.servicemix.jbi.itests.AbstractIntegrationTest.getOsgiService(AbstractIntegrationTest.java:91)
      [12:19:01]: 	at org.apache.servicemix.jbi.itests.AbstractIntegrationTest.getOsgiService(AbstractIntegrationTest.java:49)
      [12:19:01]: 	at org.apache.servicemix.jbi.itests.ManagementTest.getAdminCommands(ManagementTest.java:137)
      [12:19:01]: 	at org.apache.servicemix.jbi.itests.ManagementTest.testInstallUninstall(ManagementTest.java:64)
      [12:19:01]: 	... 25 more
      

        Activity

        Gert Vanthienen added a comment -

        Increased the time-out on the ServiceTracker in http://svn.apache.org/viewvc?view=revision&revision=904478


          People

          • Assignee:
            Gert Vanthienen
            Reporter:
            Gert Vanthienen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development