Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.2.0
    • Labels:
      None
    • Environment:

      Windows XP

      Description

      Most OSGi containers when run on the standard Windows XP console, have a command history, so that you can enter old commands easily by just hitting the 'up' key on the console and then pressing enter when you've got the one you need.
      This can be esp. handy when running long command lines over and over, e.g.
      install file:/Z:/samples/service-grid-test-deployables/spring-osgi-bundle/target/it-repo-samples-spring-osgi-bundle-2.0-SNAPSHOT.jar

      I think this command history is a standard feature of the windows shell, that OSGi containers like Felix and Equinox (and other Java programs) simply work with.
      However, the SMX4 GShell somehow managed to switch off this feature. So no command history in SMX4 Kernel. I have to type repeated commands in by hand over and over again - quite annoying when you use SMX4 a lot

        Activity

        Guillaume Nodet added a comment -

        Has anyone else been able to reproduce this behavior on windows?

        Edell Nolan added a comment -

        If I do "Ctrl-p" I can get the previous commands.
        but you have to do this otherwise you can't get the previous command.

        David Bosschaert added a comment -

        Interesting, didn't know about the Ctrl-P thing.
        In any case, in other OSGi container shells, such as the default Felix shell and the default Equinox one, simply pressing the 'up' arrow gives you your previous commands. I guess they inherit this from the windows shell. SMX seems to have disabled this inherited feature.

        Guillaume Nodet added a comment -

        We're using jline which should support that on windows and unix platforms. Windows supports that natively, but not unix console.

        Guillaume Nodet added a comment -

        I've tried on XP and it seems the history works well for me ...

        Chris Custine added a comment -

        It works on Windows XP for me as well. This issue specifically lists Windows XP as the environment so I'm not sure what the problem could be.

        Edell Nolan added a comment -

        Hi,

        I have just built a kit from trunk at apache and the up arrow is now working for me. Looks like this has been fixed on trunk.

        Edell.

        Chris Custine added a comment -

        This seems to be working for everyone now, so there must have been an upstream fix in a recent GShell build that solved this since the jline version hasn't changed. Marking as fixed for now, if anyone experiences this issue again they can reopen.

        Greg Lucas added a comment -

        For me, on WinXP: ctrl-p and ctrl-n work fine, but the arrow keys do not. Not clear from the comments so far whether that is expected?

        Chris Custine added a comment -

        Based on Greg's experience, I am going to reopen this so that we can get to the bottom of it.

        Chris Custine added a comment -

        This has been fixed in Karaf, so I am marking this as resolved here.


          People

          • Assignee:
            Chris Custine
            Reporter:
            David Bosschaert
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development