Uploaded image for project: 'ServiceMix 4'
  1. ServiceMix 4
  2. SMX4-988

should add delay to camel timer of camel-nmr and camel-nmr-blueprint example so that the nmr endpoint get chance to create

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.4.0
    • Component/s: None
    • Labels:
      None

      Description

      to avoid the exception like
      org.apache.servicemix.nmr.api.ServiceMixException: Could not dispatch exchange. No matching endpoints.
      at org.apache.servicemix.nmr.core.FlowRegistryImpl.dispatch(FlowRegistryImpl.java:110)
      which is caused by the timer started but the nmr endpoint not ready yet

        Activity


          People

          • Assignee:
            ffang Freeman Fang
            Reporter:
            ffang Freeman Fang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development