Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.2.0
    • Fix Version/s: 4.4.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows Vista SP2, JDK 1.6.0_23

      Description

      After deploying the attached route, I'm getting the "Caused by: org.apache.camel.ResolveEndpointFailedException: Failed to resolve endpoint: restlet://http://0.0.0.0:8192/sample due to: No component found with scheme: restlet" message.

      The work around suggested at http://fusesource.com/forums/thread.jspa?threadID=2493 seems to resolve it, but it is unclear to me how the OSGi reference or the configuration of the endpoints in Java code change the picture.

      1. sampleroute-1.0.jar
        4 kB
        Fernando Ribeiro

        Issue Links

          Activity

          davsclaus Claus Ibsen added a comment -

          Moved to SMX as its OSGi / Container related.

          fribeiro Fernando Ribeiro added a comment -

          Duplicate of SMX4-744.

          ffang Freeman Fang added a comment -

          I'd keep it open until SMX4-744 is done


            People

            • Assignee:
              ffang Freeman Fang
              Reporter:
              fribeiro Fernando Ribeiro
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development