Uploaded image for project: 'ServiceMix 4'
  1. ServiceMix 4
  2. SMX4-687

ServiceMix 4.3.0-fuse-02-00 does not start correctly with fresh unzip on Windows

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.3.0
    • Fix Version/s: 4.4.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows 7

      Description

      I've seen this on two different systems at two different companies. Both have web proxies in place that have caused other issues with the embedded MVN framework in SMX4.

      See: http://fusesource.com/issues/browse/PROD-503

      1. servicemix-debug.log
        498 kB
        Matt Pavlovich
      2. servicemix.log
        39 kB
        Matt Pavlovich

        Activity

        mattrpav Matt Pavlovich added a comment -

        Default data/log/servicemix.log

        mattrpav Matt Pavlovich added a comment -

        Relevant exception:

        Caused by: java.lang.RuntimeException: URL [mvn:org.apache.karaf/apache-karaf/2.0.0-fuse-00-00/xml/features] could not be resolved.
        at org.ops4j.pax.url.mvn.internal.Connection.getInputStream(Connection.java:195)[1:org.ops4j.pax.url.mvn:1.1.3]
        at org.apache.karaf.features.internal.RepositoryImpl.load(RepositoryImpl.java:92)[8:org.apache.karaf.features.core:2.0.0.fuse-01-00]

        mattrpav Matt Pavlovich added a comment -

        Log file w/ DEBUG enabled

        mattrpav Matt Pavlovich added a comment -

        Limited bundles start:

        karaf@root> list
        START LEVEL 100
        ID State Blueprint Level Name
        [ 0] [Active ] [ ] [ 0] OSGi System Bundle (3.6.0.v20100517)
        [ 1] [Active ] [ ] [ 5] OPS4J Pax Url - mvn: (1.1.3)
        [ 2] [Active ] [ ] [ 5] OPS4J Pax Url - wrap: (1.1.3)
        [ 3] [Active ] [ ] [ 8] OPS4J Pax Logging - API (1.5.3)
        [ 4] [Active ] [ ] [ 8] OPS4J Pax Logging - Service (1.5.3)
        [ 5] [Active ] [ ] [ 10] Apache Felix Configuration Admin Service (1.2.4)
        [ 6] [Active ] [ ] [ 11] Apache Felix File Install (3.0.2)
        [ 7] [Active ] [Created ] [ 20] Apache Aries Blueprint Bundle (0.2.0.incubating)
        [ 8] [Active ] [Created ] [ 30] Apache Karaf :: Features Core (2.0.0.fuse-01-00)
        [ 9] [Active ] [Created ] [ 30] Apache Karaf :: Admin Core (2.0.0.fuse-01-00)
        [ 10] [Active ] [Created ] [ 30] Apache Karaf :: Shell OSGi Commands (2.0.0.fuse-01-00)
        [ 11] [Active ] [Created ] [ 30] Apache Karaf :: Management (2.0.0.fuse-01-00)
        [ 12] [Active ] [Created ] [ 30] Apache Karaf :: Admin Command (2.0.0.fuse-01-00)
        [ 13] [Active ] [Created ] [ 30] Apache Karaf :: Shell Log Commands (2.0.0.fuse-01-00)
        [ 14] [Active ] [ ] [ 30] Apache Aries JMX Blueprint Bundle (0.2.0.incubating)
        [ 15] [Active ] [Created ] [ 30] Apache Karaf :: Admin Management (2.0.0.fuse-01-00)
        [ 16] [Active ] [Created ] [ 30] Apache Karaf :: Shell Console (2.0.0.fuse-01-00)
        [ 17] [Active ] [Created ] [ 30] Apache Karaf :: JAAS Modules (2.0.0.fuse-01-00)
        [ 18] [Active ] [Created ] [ 30] Apache Karaf :: Blueprint Deployer (2.0.0.fuse-01-00)
        [ 19] [Active ] [Created ] [ 30] Apache Karaf :: Shell Development Commands (2.0.0.fuse-01-00)
        [ 20] [Active ] [Created ] [ 30] Apache Karaf :: Features Management (2.0.0.fuse-01-00)
        [ 21] [Active ] [ ] [ 30] Apache Felix Gogo Shell Runtime (0.4.0)
        [ 22] [Active ] [Created ] [ 30] Apache Karaf :: Shell PackageAdmin Commands (2.0.0.fuse-01-00)
        [ 23] [Active ] [Created ] [ 30] Apache Karaf :: Shell SSH (2.0.0.fuse-01-00)
        [ 24] [Active ] [Created ] [ 30] Apache Karaf :: JAAS Config (2.0.0.fuse-01-00)
        [ 25] [Active ] [Created ] [ 30] Apache Karaf :: Spring Deployer (2.0.0.fuse-01-00)
        [ 26] [Active ] [ ] [ 30] Apache Aries JMX Bundle (0.2.0.incubating)
        [ 27] [Active ] [Created ] [ 30] Apache Karaf :: Shell Various Commands (2.0.0.fuse-01-00)
        [ 28] [Active ] [ ] [ 30] Apache MINA Core (2.0.0.RC1)
        [ 29] [Active ] [ ] [ 30] Apache Mina SSHD :: Core (0.4.0)
        [ 30] [Active ] [Created ] [ 30] Apache Karaf :: Features Command (2.0.0.fuse-01-00)
        [ 31] [Active ] [Created ] [ 30] Apache Karaf :: Features Deployer (2.0.0.fuse-01-00)
        karaf@root>

        mattrpav Matt Pavlovich added a comment -

        A find and grep on the SMX install does not reveal the OSGI MVN repo explicitly listed. Stored in a bundle?

        10:41:01,517 | DEBUG | Thread-6 | Connection | .pax.url.mvn.internal.Connection 190 | 1 - org.ops4j.pax.url.mvn - 1.1.3 | Could not download [Version [2.0.0-fuse-00-00] from URL [http://osgi.sonatype.org/content/groups/pax-runner/org/apache/karaf/apache-karaf/2.0.0-fuse-00-00/apache-karaf-2.0.0-fuse-00-00-features.xml

        File search for string matching osgi.sonatype.org:

        From root SMX install folder apache-servicemix-4.3.0-fuse-02-00/

        $ find . -type f -exec grep -il osgi.sonatype.org {} \;
        grep: ./data/cache/org.eclipse.osgi/.manager/.tmp4531193532013171169.instance: Permission denied
        ./data/log/servicemix-debug.log
        ./data/log/servicemix.log
        grep: ./lock: Permission denied

        mattrpav Matt Pavlovich added a comment -

        Looking for karaf 2.0.0-fuse-00-00 feature, but fuse-01-00 is installed in system/

        apache-servicemix-4.3.0-fuse-02-00\system\org\apache\karaf\apache-karaf\2.0.0-fuse-01-00\

        mattrpav Matt Pavlovich added a comment -

        Type-o in activemq-karaf features file, looking for one rev older version of apache-karaf/.../xml/features

        apache-servicemix-4.3.0-fuse-02-00/system/org/apache/activemq/activemq-karaf/5.4.1-fuse-00-00
        $ diff activemq-karaf-5.4.1-fuse-00-00-features.xml activemq-karaf-5.4.1-fuse-00-00-features.xml.orig
        21c21
        < <repository>mvn:org.apache.karaf/apache-karaf/2.0.0-fuse-01-00/xml/features</repository>

        > <repository>mvn:org.apache.karaf/apache-karaf/2.0.0-fuse-00-00/xml/features</repository>

        mattrpav Matt Pavlovich added a comment -

        The type-o is simple enough to fix-- what is troubling is that the pax.url.mvn was looking to a repo that doesn't appear to be in any config file or any txt file in the system/ folder. Very difficult to troubleshoot.

        Should SMX be going out to an undocumented/configured site to pull in features?
        10:41:01,517 | DEBUG | Thread-6 | Connection | .pax.url.mvn.internal.Connection 190 | 1 - org.ops4j.pax.url.mvn - 1.1.3 | Could not download [Version [2.0.0-fuse-00-00] from URL [http://osgi.sonatype.org/content/groups/pax-runner/org/apache/karaf/apache-karaf/2.0.0-fuse-00-00/apache-karaf-2.0.0-fuse-00-00-features.xml

        jbonofre Jean-Baptiste Onofré added a comment -

        Thanks for this detailed explanation.

        We will take a look on this issue.

        mattrpav Matt Pavlovich added a comment - - edited

        I patched pax-url to no longer always return a hard-coded (and only documented in source). pax-url-mvn 1.2.2 should no longer look to the http://osgi.sonatype.org/content/groups/pax-runner repository all the time.

        See: http://issues.ops4j.org/browse/PAXURL-92

        I suggest adding these two properties to the etc/org.ops4j.pax.url.mvn.cfg file:

        # Default this to false. Its just weird to use repos that you don't know about

        org.ops4j.pax.url.mvn.useFallbackRepositories=false

        # Uncomment if you are behind a web proxy. PAX URL will use the proxy settings

        # from the Maven conf/settings.xml file

        # org.ops4j.pax.url.mvn.proxySupport=true

        gertvanthienen Gert Vanthienen added a comment -

        Have we been able to verify this with an Apache SMX4 kit as wel, because all the information in the issue is about the FuseSource kits?

        jbonofre Jean-Baptiste Onofré added a comment -

        I try to reproduce on Windows VirtualBox with ServiceMix 4.3.0-SNAPSHOT.

        splatch Łukasz Dywicki added a comment -

        Hi,
        I run 4.3.0 SNAPSHOT on Windows 7 without problems. Only one note - I don't have any proxy.

        mattrpav Matt Pavlovich added a comment -

        I downloaded latest 4.3.0-SNAPSHOT and it worked fine.

        Note: To simulate "badly configured proxy behavior", you can remove your computer from the network and run "off line".

        It would be great to get PAX URL upgraded to 1.2.4 to solve for the default and fallback repository handling, and have the above configuration parameters added to the default etc/org.ops4j.pax.url.mvn.cfg file.

        Thanks!
        Matt

        jbonofre Jean-Baptiste Onofré added a comment -

        The etc/org.ops4j.pax.url.cfg file comes from Karaf, it's not overrided by ServiceMix.

        Moreover, ServiceMix 4.3.0-SNAPSHOT uses Karaf 2.1.3 and so PAX URL 1.2.1. The upgrade to PAX URL 1.2.4 is planned in ServiceMix 4.4.0 with the update to Karaf 2.2.x.

        So, I move this bug into 4.4.0-SNAPSHOT version.

        gertvanthienen Gert Vanthienen added a comment -

        It looks like the FuseSource PROD issue is fixed by now and the upgrade to the newer version of Pax Url Maven has been done as well.


          People

          • Assignee:
            jbonofre Jean-Baptiste Onofré
            Reporter:
            mattrpav Matt Pavlovich
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development