Uploaded image for project: 'ServiceMix 4'
  1. ServiceMix 4
  2. SMX4-674

ActiveMQ 5.4.1 feature has a missing dependency

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.3.0
    • Component/s: None
    • Labels:
      None

      Description

      karaf@root> features:install activemq
      Error executing command: Could not start bundle mvn:org.apache.activemq/activemq-console/5.4.1 in feature(s) : Unresolved constraint in bundle org.apache.activemq.activemq-console [88]: Unable to resolve 88.0: missing requirement [88.0] package; (package=org.jasypt.encryption.pbe) - [88.0] package; (package=org.jasypt.encryption.pbe)

      Easily remedied by first installing a wrapped version of the dependency:

      karaf@root> install wrap:mvn:org.jasypt/jasypt/1.6

      This was incorrectly reported on Karaf project: https://issues.apache.org/jira/browse/KARAF-278

        Attachments

          Activity

            People

            • Assignee:
              ffang Freeman Fang
              Reporter:
              earcam Caspar MacRae
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: