ServiceMix 4
  1. ServiceMix 4
  2. SMX4-581

xpp3 bundle is missing META-INF/services/org.xmlpull.v1.XmlPullParserFactory needed to support zero configuation operation mode

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.3.0
    • Component/s: Bundles
    • Labels:
      None
    • Environment:

      Using the bundle outside of the service mix project as osgi-bundle of XPP3 implementation

      Description

      Used version (in maven location format);
      <dependency>
      <groupId>org.apache.servicemix.bundles</groupId>
      <artifactId>org.apache.servicemix.bundles.xpp3</artifactId>
      <version>1.1.4c_1</version>
      </dependency>

      The xml pull parser is not working without giving the implementation class names to the XmlPullParserFactory newInstance due the missing service configuration file.
      newinstance(null, null)
      To simplify usage and to support working with the bundle as with the actual implementation jar file, this should work.

      Exception given below:

      Caused by: org.xmlpull.v1.XmlPullParserException: caused by: org.xmlpull.v1.XmlPullParserException: resource not found: /META-INF/services/org.xmlpull.v1.XmlPullParserFactory make sure that parser implementing XmlPull API is available
      at org.xmlpull.v1.XmlPullParserFactory.newInstance(XmlPullParserFactory.java:294) ~[org.apache.servicemix.bundles.xpp3-1.1.4c_3.jar:na]

      IMO, this service config file should be part of the bundle.

      Workaround: We created a fragment bundle containing that file.
      META-INF/services/org.xmlpull.v1.XmlPullParserFactory content:
      org.xmlpull.mxp1.MXParser,org.xmlpull.mxp1_serializer.MXSerializer

        Activity

        Steffen Gürtler added a comment -

        Edited description

        Jean-Baptiste Onofré added a comment -

        Revision 988834.

        Brian Topping added a comment -

        Could this be minimally deployed to snapshots.apache.org and/or released? I suppose there's not a lot of demand for it, but as JB made the effort to get it resolved, it would be great if it was accessible


          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Steffen Gürtler
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development