ServiceMix 4
  1. ServiceMix 4
  2. SMX4-422

CamelCXF Producer does not work if deployed inside JBI SU

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.2.0
    • Fix Version/s: 4.2.0
    • Component/s: None
    • Labels:
      None

      Description

      1. install SMX 4 snapshot
      2. Unzip the project
      3. Build it starting from the root, the result is a camelcxf-smxcxf-sa.zip in
      camelcxfproblem/jbi/camelcxf-smxcxf/camelcxf-smxcxf-sa/target/camelcxf-smxcxf-sa.zip

      This JBI SA consists of a number of SUs (see camelcxfproblem/jbi/camelcxf-smxcxf/) but the SU of interest is
      camelcxf-smxcxf-camel1-su. The route is supposed to work as follows :

      • an http message is picked up from an http jbi endpoint (see camelcxf-smxcxf-http-su) and is forwarded to a remote addess using a
        camelcxf component. This request will be handled by cxfbc, cxfse and eip SUnits and the response will be forwarded to
        log:soapresponse. Camel context also declares another route. But at the moment the first route does not work (camelcxf)
        due to NoConduitInitiator...

      4. So, to reproduce an issue, just drop this SA into /deploy folder and then start camelcxfproblem//client.html and send a SOAP
      message, and you'll see the exception...

      Note that I've commented <import> statements in camelcxf-smxcxf-camel1-su xbean.xml (and corresponding deps in
      camelcxfproblem/jbi/camelcxf-smxcxf/camelcxf-smxcxf-camel1-su/pom.xml), just for you to start from where I started. I've tried with
      imports too but it did nnot make any difference
      [ Show » ]
      Sergey Beryozkin added a comment - 10/Nov/09 11:35 AM 1. install SMX 4.2-fuse-SNAPSHOT 2. Unzip the project 3. Build it starting from the root, the result is a camelcxf-smxcxf-sa.zip in camelcxfproblem/jbi/camelcxf-smxcxf/camelcxf-smxcxf-sa/target/camelcxf-smxcxf-sa.zip This JBI SA consists of a number of SUs (see camelcxfproblem/jbi/camelcxf-smxcxf/) but the SU of interest is camelcxf-smxcxf-camel1-su. The route is supposed to work as follows :

      • an http message is picked up from an http jbi endpoint (see camelcxf-smxcxf-http-su) and is forwarded to a remote addess using a camelcxf component. This request will be handled by cxfbc, cxfse and eip SUnits and the response will be forwarded to log:soapresponse. Camel context also declares another route. But at the moment the first route does not work (camelcxf) due to NoConduitInitiator...

      4. So, to reproduce an issue, just drop this SA into /deploy folder and then start camelcxfproblem//client.html and send a SOAP message, and you'll see the exception... Note that I've commented <import> statements in camelcxf-smxcxf-camel1-su xbean.xml (and corresponding deps in camelcxfproblem/jbi/camelcxf-smxcxf/camelcxf-smxcxf-camel1-su/pom.xml). I've tried with imports too but it did not make any difference

      1. SMX4-422.patch
        0.5 kB
        Willem Jiang
      2. camelcxfProblem.zip
        33 kB
        Sergey Beryozkin

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          8d 21h 52m 1 Freeman Fang 19/Nov/09 09:32
          Jeff Turner made changes -
          Project Import Sat Nov 27 01:13:56 EST 2010 [ 1290838436878 ]
          Freeman Fang added a comment -

          revert the patch as it's not the real fix, take a look at camel-2216

          http://svn.apache.org/viewvc?rev=883964&view=rev

          Willem Jiang made changes -
          Link This issue is depended upon by CAMEL-2216 [ CAMEL-2216 ]
          Freeman Fang made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Freeman Fang added a comment -

          apply patch on behalf of Willem with thanks
          http://svn.apache.org/viewvc?rev=882087&view=rev

          Willem Jiang made changes -
          Attachment SMX4-422.patch [ 18633 ]
          Willem Jiang added a comment -

          Please apply this patch on the features module.

          Willem Jiang added a comment -

          Since we can use the cxf jars in the SMX 4 from camel-cxf component, and camel-osgi will help the camel-core to load the camel-cxf bundle , so please don't wrap cxf and camel-cxf jars into the camel-su.

          Willem Jiang added a comment -

          Hi Sergey,

          After digging the code for a while I guess your issue is caused by the CXF BusFactory created a wrong version of BusFactory.
          When I added this system property into the SMX/etc/system.properties , the error went way.

          org.apache.cxf.bus.factory=org.apache.cxf.bus.spring.SpringBusFactory
          

          Willem

          Willem Jiang made changes -
          Assignee Willem Jiang [ njiang ]
          Willem Jiang added a comment -

          I can reproduce this error on windows box, but in mac OSX, the client can invoke the service without any error.

          Sergey Beryozkin made changes -
          Summary CamelCXF does not work if deployed inside JBI SU CamelCXF Producer does not work if deployed inside JBI SU
          Sergey Beryozkin made changes -
          Field Original Value New Value
          Attachment camelcxfProblem.zip [ 18613 ]
          Sergey Beryozkin created issue -

            People

            • Assignee:
              Willem Jiang
              Reporter:
              Sergey Beryozkin
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development