Uploaded image for project: 'ServiceMix'
  1. ServiceMix
  2. SM-4937

add servlet-compatible bundle

    XMLWordPrintableJSON

Details

    • Task
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • bundles-2021.11
    • bundles
    • None

    Description

      In OSGi container, it's common that some bundles require servlet api 3.x while others require servlet api 4.x. To address this dependency chain conflict issue, a servlet-compatible bundle can be introduced. A servlet-compatible bundle is a fragment bundle which can be attached to serlvet api 4.x bundle and also export servlet 3.x package.

      More discussion please take a look at https://github.com/apache/cxf/pull/767#discussion_r607129654

      Attachments

        Activity

          People

            ffang Freeman Yue Fang
            ffang Freeman Yue Fang
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: