Uploaded image for project: 'ServiceMix'
  1. ServiceMix
  2. SM-2323

ServiceMix freezes if bundled is refreshed after feature install

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 5.0.1
    • Fix Version/s: 5.6.3
    • Component/s: None
    • Labels:
      None
    • Environment:

      Linux MacOs

      Description

      If you install a feature from a feature descriptor that causes a refresh at first startup ServiceMix freezes (after second startup install works). e.g. console prints:

      Refreshing bundles org.springframework.jms (76)
      

      Log contains someting like:

      15:12:51,639 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org
      .apache.cxf.cxf-rt-features-clustering
      15:12:51,642 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org
      .apache.cxf.cxf-api
      15:12:51,646 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.cxf.cxf-rt-transports-http
      15:12:51,651 | INFO  | xFrameworkWiring | ContextHandler                   | 101 - org.eclipse.jetty.util - 7.6.9.v20130131 | stopped HttpServiceContext{httpContext=DefaultHttpContext{org.apache.cxf.cxf-rt-transports-http - 125}}
      15:12:51,653 | INFO  | xFrameworkWiring | HttpServiceFactoryImpl           | 123 - org.ops4j.pax.web.pax-web-runtime - 1.1.17 | Unbinding bundle: [org.apache.cxf.cxf-rt-transports-http [125]]
      15:12:51,654 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.cxf.cxf-rt-bindings-coloc
      15:12:51,657 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.camel.camel-cxf-transport
      15:12:51,659 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.cxf.cxf-rt-frontend-jaxws
      15:12:51,660 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.cxf.cxf-rt-transports-http-jetty
      15:12:51,663 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.camel.camel-cxf
      15:12:51,665 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.activemq.activemq-osgi
      15:12:51,668 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.cxf.cxf-rt-ws-addr
      15:12:51,669 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.cxf.karaf.cxf-karaf-commands
      15:12:51,672 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.cxf.cxf-rt-ws-policy
      15:12:51,676 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.cxf.cxf-rt-core
      15:12:51,678 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 139
      15:12:51,678 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 125
      15:12:51,678 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 119
      15:12:51,678 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 137
      15:12:51,678 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 127
      15:12:51,678 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 151
      15:12:51,678 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 145
      15:12:51,678 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 162
      15:12:51,678 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 118
      15:12:51,679 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 154
      15:12:51,679 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 140
      15:12:51,679 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 153
      15:12:51,679 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 135
      15:12:51,679 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 138
      15:12:51,679 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 141
      15:12:51,679 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 156
      15:12:51,679 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 115
      15:12:51,679 | INFO  | xFrameworkWiring | CXFActivator                     | 116 - org.apache.cxf.cxf-api - 2.7.10 | Removing the extensions for bundle 155
      15:12:51,682 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.cxf.cxf-rt-ws-rm
      15:12:51,684 | INFO  | xFrameworkWiring | BlueprintExtender                | 7 - org.apache.aries.blueprint.core - 1.4.0 | Destroying BlueprintContainer for bundle org.apache.cxf.cxf-rt-frontend-jaxrs
      15:12:52,460 | WARN  | Thread-39        | BndUtils                         | 2 - org.ops4j.pax.url.wrap - 1.3.7 | Bundle cannot be generated
      java.io.IOException: Pipe closed
              at java.io.PipedInputStream.checkStateForReceive(PipedInputStream.java:261)[:1.7.0_51]
              at java.io.PipedInputStream.receive(PipedInputStream.java:227)[:1.7.0_51]
              at java.io.PipedOutputStream.write(PipedOutputStream.java:149)[:1.7.0_51]
              at java.util.zip.DeflaterOutputStream.deflate(DeflaterOutputStream.java:253)[:1.7.0_51]
              at java.util.zip.ZipOutputStream.closeEntry(ZipOutputStream.java:238)[:1.7.0_51]
              at aQute.lib.osgi.Jar.writeResource(Jar.java:305)[2:org.ops4j.pax.url.wrap:1.3.7]
              at aQute.lib.osgi.Jar.write(Jar.java:211)[2:org.ops4j.pax.url.wrap:1.3.7]
              at org.ops4j.pax.swissbox.bnd.BndUtils$1.run(BndUtils.java:174)[2:org.ops4j.pax.url.wrap:1.3.7]
      

        Activity

        sobkowiak Krzysztof Sobkowiak added a comment -

        This is an issue related to PAX Web included in Karaf 2.3.x (see SM-2287)

        sobkowiak Krzysztof Sobkowiak added a comment -

        Removing eventadmin from featuresBoot should help (if you don't need this feature)

        falkmarcus Marcus Abels added a comment -

        Yes, this worked. Somehow the startup state of my Spring DM Moduls is not shown with list, but they are actually started. Only if servicemix is restarted it is shown correctly.

        lightoze Vladimir Kulev added a comment -

        Still happens on 5.1.1

        sobkowiak Krzysztof Sobkowiak added a comment -

        The problem is caused by https://ops4j1.jira.com/browse/PAXWEB-649, but the fix for the problem is not included in Pax Web included in ServiceMix 5.1.x. We are not able to solve this problem. The only solution is to add the features which cause the refres to featuresBoot or remove the eventadmin from featuresBoot.

        This problem should not happen in Karaf 2.4.x based distributions, also 5.3.x, 5.4.x, ...

        sobkowiak Krzysztof Sobkowiak added a comment -

        This problem doesn't occur since Karaf 2.4.x based distributions


          People

          • Assignee:
            Unassigned
            Reporter:
            falkmarcus Marcus Abels
          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development