ServiceMix
  1. ServiceMix
  2. SM-2292 Upgrade to Camel 2.13.1
  3. SM-2303

ActiveMQ web console not installable after upgrade to 5.9.1

    Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.1.0, 6.0.0
    • Fix Version/s: 5.1.0, 6.0.0.M1, 6.0.0
    • Component/s: assemblies
    • Labels:
      None

      Description

      When installing the new web console following error is thrown

      Caused by: org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter]: Constructor threw exception; nested exception is java.lang.NoClassDefFoundError: javax/xml/stream/XMLStreamException
      	at org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:163)[190:org.apache.activemq.activemq-web-console:5.9.1]
      	at org.springframework.beans.factory.support.SimpleInstantiationStrategy.instantiate(SimpleInstantiationStrategy.java:87)[190:org.apache.activemq.activemq-web-console:5.9.1]
      	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.instantiateBean(AbstractAutowireCapableBeanFactory.java:1030)[190:org.apache.activemq.activemq-web-console:5.9.1]
      	... 60 more
      Caused by: java.lang.NoClassDefFoundError: javax/xml/stream/XMLStreamException
      	at org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter.<init>(AnnotationMethodHandlerAdapter.java:203)[190:org.apache.activemq.activemq-web-console:5.9.1]
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)[:1.7.0_55]
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)[:1.7.0_55]
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)[:1.7.0_55]
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:526)[:1.7.0_55]
      	at org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:148)[190:org.apache.activemq.activemq-web-console:5.9.1]
      	... 62 more
      Caused by: java.lang.ClassNotFoundException: javax.xml.stream.XMLStreamException not found by org.apache.activemq.activemq-web-console [190]
      	at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1532)[org.apache.felix.framework-4.2.1.jar:]
      	at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75)[org.apache.felix.framework-4.2.1.jar:]
      	at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1955)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)[:1.7.0_55]
      	... 68 more
      
      1. servicemix.log
        113 kB
        Krzysztof Sobkowiak

        Issue Links

          Activity

          Krzysztof Sobkowiak created issue -
          Krzysztof Sobkowiak made changes -
          Field Original Value New Value
          Link This issue relates to AMQ-5167 [ AMQ-5167 ]
          Krzysztof Sobkowiak made changes -
          Attachment servicemix.log [ 12645853 ]
          Krzysztof Sobkowiak made changes -
          Description When installing the new web console following error is thrown

          {code}
          Caused by: org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter]: Constructor threw exception; nested exception is java.lang.NoClassDefFoundError: javax/xml/stream/XMLStreamException
          at org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:163)[190:org.apache.activemq.activemq-web-console:5.9.1]
          at org.springframework.beans.factory.support.SimpleInstantiationStrategy.instantiate(SimpleInstantiationStrategy.java:87)[190:org.apache.activemq.activemq-web-console:5.9.1]
          at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.instantiateBean(AbstractAutowireCapableBeanFactory.java:1030)[190:org.apache.activemq.activemq-web-console:5.9.1]
          ... 60 more
          Caused by: java.lang.NoClassDefFoundError: javax/xml/stream/XMLStreamException
          at org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter.<init>(AnnotationMethodHandlerAdapter.java:203)[190:org.apache.activemq.activemq-web-console:5.9.1]
          at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)[:1.7.0_55]
          at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)[:1.7.0_55]
          at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)[:1.7.0_55]
          at java.lang.reflect.Constructor.newInstance(Constructor.java:526)[:1.7.0_55]
          at org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:148)[190:org.apache.activemq.activemq-web-console:5.9.1]
          ... 62 more
          Caused by: java.lang.ClassNotFoundException: javax.xml.stream.XMLStreamException not found by org.apache.activemq.activemq-web-console [190]
          at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1532)[org.apache.felix.framework-4.2.1.jar:]
          at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75)[org.apache.felix.framework-4.2.1.jar:]
          at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1955)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:358)[:1.7.0_55]
          ... 68 more
          {code}
          Krzysztof Sobkowiak made changes -
          Fix Version/s 5.1.0 [ 12326660 ]
          Fix Version/s 6.0.0 [ 12326661 ]
          Krzysztof Sobkowiak made changes -
          Link This issue blocks SM-2292 [ SM-2292 ]
          Krzysztof Sobkowiak added a comment -

          I've created a pull request for AMQ-5167

          Krzysztof Sobkowiak made changes -
          Assignee Krzysztof Sobkowiak [ sobkowiak ]
          Krzysztof Sobkowiak made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Krzysztof Sobkowiak made changes -
          Parent SM-2292 [ 12712054 ]
          Issue Type Bug [ 1 ] Sub-task [ 7 ]
          Krzysztof Sobkowiak made changes -
          Link This issue blocks SM-2292 [ SM-2292 ]
          Krzysztof Sobkowiak added a comment -

          As workaround until AMQ-5167 is fixed I have done following changes

          • shaded the activemq-web-console in ServiceMix (as activemq-web module) and modified the OSGi manifest by adding DynamicImport-Package: * using the ManifestResourceTransformer. I tried to use maven-bundle-plugin to generate a new manifest but I couldn't manage to work shade, bundle plugin and war packaging type together. Perhaps someone have an idea how to make it better
          • created a new feature amq-web-console (as internal feature). If some needs the ActiveMQ console can use this feature.

          We can remove the shaded web console after the AMQ issue is solved.

          Krzysztof Sobkowiak added a comment -

          I have renamed the amq-web-console feature to activemq-web-console with version 5.9.1.SMX so people can simply install the console like previously, using the standard feature name

          Fixed in

          Krzysztof Sobkowiak made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Krzysztof Sobkowiak made changes -
          Link This issue relates to SM-2311 [ SM-2311 ]
          Krzysztof Sobkowiak made changes -
          Fix Version/s 6.0.0.M1 [ 12329337 ]

            People

            • Assignee:
              Krzysztof Sobkowiak
              Reporter:
              Krzysztof Sobkowiak
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development