ServiceMix
  1. ServiceMix
  2. SM-2077

ServiceMix wsn2005 doesn't start correctly on SMX3

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.4.0
    • Component/s: servicemix-assembly
    • Labels:
      None
    • Environment:

      Linux,
      JDK Sun 1.6

      Description

      On ServiceMix 3.4-SNAPSHOT, at startup, the ServiceMix WSN2005 component doesn't start:

      INFO - ComponentMBeanImpl - Initializing component: servicemix-wsn2005
      ERROR - ComponentMBeanImpl - Could not start component
      javax.jbi.JBIException: Error calling init
      at org.apache.servicemix.common.AsyncBaseLifeCycle.init(AsyncBaseLifeCycle.java:211)
      at org.apache.servicemix.common.SyncLifeCycleWrapper.init(SyncLifeCycleWrapper.java:46)
      at org.apache.servicemix.jbi.framework.ComponentMBeanImpl.init(ComponentMBeanImpl.java:201)
      at org.apache.servicemix.jbi.framework.ComponentMBeanImpl.doStart(ComponentMBeanImpl.java:287)
      at org.apache.servicemix.jbi.framework.ComponentMBeanImpl.start(ComponentMBeanImpl.java:216)
      at org.apache.servicemix.jbi.framework.InstallationService.install(InstallationService.java:331)
      at org.apache.servicemix.jbi.framework.AutoDeploymentService.updateComponent(AutoDeploymentService.java:288)
      at org.apache.servicemix.jbi.framework.AutoDeploymentService.updateArchive(AutoDeploymentService.java:251)
      at org.apache.servicemix.jbi.framework.AutoDeploymentService.monitorDirectory(AutoDeploymentService.java:658)
      at org.apache.servicemix.jbi.framework.AutoDeploymentService.access$800(AutoDeploymentService.java:63)
      at org.apache.servicemix.jbi.framework.AutoDeploymentService$1.run(AutoDeploymentService.java:622)
      at java.util.TimerThread.mainLoop(Timer.java:512)
      at java.util.TimerThread.run(Timer.java:462)
      Caused by: javax.naming.NamingException: scheme java not recognized
      at org.apache.xbean.spring.jndi.DefaultContext.lookup(DefaultContext.java:131)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at org.apache.servicemix.wsn.component.WSNComponent.lookupConnectionFactory(WSNComponent.java:255)
      at org.apache.servicemix.wsn.component.WSNComponent.doInit(WSNComponent.java:144)
      at org.apache.servicemix.common.AsyncBaseLifeCycle.init(AsyncBaseLifeCycle.java:205)
      ... 12 more
      ERROR - InstallationService - Failed to start Component: servicemix-wsn2005
      javax.jbi.JBIException: Error calling init
      at org.apache.servicemix.common.AsyncBaseLifeCycle.init(AsyncBaseLifeCycle.java:211)
      at org.apache.servicemix.common.SyncLifeCycleWrapper.init(SyncLifeCycleWrapper.java:46)
      at org.apache.servicemix.jbi.framework.ComponentMBeanImpl.init(ComponentMBeanImpl.java:201)
      at org.apache.servicemix.jbi.framework.ComponentMBeanImpl.doStart(ComponentMBeanImpl.java:287)
      at org.apache.servicemix.jbi.framework.ComponentMBeanImpl.start(ComponentMBeanImpl.java:216)
      at org.apache.servicemix.jbi.framework.InstallationService.install(InstallationService.java:331)
      at org.apache.servicemix.jbi.framework.AutoDeploymentService.updateComponent(AutoDeploymentService.java:288)
      at org.apache.servicemix.jbi.framework.AutoDeploymentService.updateArchive(AutoDeploymentService.java:251)
      at org.apache.servicemix.jbi.framework.AutoDeploymentService.monitorDirectory(AutoDeploymentService.java:658)
      at org.apache.servicemix.jbi.framework.AutoDeploymentService.access$800(AutoDeploymentService.java:63)
      at org.apache.servicemix.jbi.framework.AutoDeploymentService$1.run(AutoDeploymentService.java:622)
      at java.util.TimerThread.mainLoop(Timer.java:512)
      at java.util.TimerThread.run(Timer.java:462)
      Caused by: javax.naming.NamingException: scheme java not recognized
      at org.apache.xbean.spring.jndi.DefaultContext.lookup(DefaultContext.java:131)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at org.apache.servicemix.wsn.component.WSNComponent.lookupConnectionFactory(WSNComponent.java:255)
      at org.apache.servicemix.wsn.component.WSNComponent.doInit(WSNComponent.java:144)
      at org.apache.servicemix.common.AsyncBaseLifeCycle.init(AsyncBaseLifeCycle.java:205)
      ... 12 more

        Activity

        Jean-Baptiste Onofré added a comment -

        I try to upgrade the conf/jndi.xml.

        Jean-Baptiste Onofré added a comment -

        It seems that you have a different JNDI name between the one defined in the ServiceMix WSN2005 components and in the main servicemix.xml file.

        I'm trying by updating the servicemix.xml JNDI entries.

        Jean-Baptiste Onofré added a comment -

        This issue is not really linked to the component but more to SMX3.

        Jean-Baptiste Onofré added a comment -

        Revision 1099390.

        Jean-Baptiste Onofré added a comment -

        Same issue with the latest Lars changes around JNDI.

        Jean-Baptiste Onofré added a comment -

        It works with the last Lars' changes.


          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development