Details

    • Regression:
      Unit Test Broken

      Description

      Currently, the SMX3 build doesn't work.

      If I disable the tests, I got:

      [INFO] Failed to resolve dependencies for one or more projects in the reactor. Reason: Unable to get dependency information: Unable to read the metadata file for artifact 'org.apache.servicemix:servicemix-http:jar': Cannot find parent: org.apache.servicemix:binding-components for project: org.apache.servicemix:servicemix-http:jbi-component:null for project org.apache.servicemix:servicemix-http:jbi-component:null
      org.apache.servicemix:servicemix-http:jar:2010.02-SNAPSHOT

      from the specified remote repositories:
      apache.snapshots (http://repository.apache.org/snapshots),
      central (http://repo1.maven.org/maven2),
      smx.m2-repo (http://svn.apache.org/repos/asf/servicemix/m2-repo/)

      Path to dependency:
      1) org.apache.servicemix:servicemix-itests:jar:3.3.3-SNAPSHOT

      With tests enabled, I got:

      Running org.apache.servicemix.lwcontainer.LwContainerComponentTest
      Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.344 sec <<< FAILURE!

      Results :

      Tests in error:
      initializationError0(org.apache.servicemix.lwcontainer.LwContainerComponentTest)

      Tests run: 1, Failures: 0, Errors: 1, Skipped: 0

      I'm gonna investigate these issues to make SMX3 build again.

        Activity

        Hide
        jbonofre Jean-Baptiste Onofré added a comment -

        Both issues look related to slf4j. I guess that we update the slf4j (directly or via a transitive dependency).

        Show
        jbonofre Jean-Baptiste Onofré added a comment - Both issues look related to slf4j. I guess that we update the slf4j (directly or via a transitive dependency).
        Hide
        jbonofre Jean-Baptiste Onofré added a comment -

        As suspected, the problem is that ServiceMix Components shared libraries uses SLF4J 1.5.8 whereas ServiceMix 3 still uses 1.4.3 version.

        For now, I "forced" the usage of SLF4J 1.4.3 version. I raised another task to upgrade to SLF4J 1.5.8.

        Revision 1054109.

        Show
        jbonofre Jean-Baptiste Onofré added a comment - As suspected, the problem is that ServiceMix Components shared libraries uses SLF4J 1.5.8 whereas ServiceMix 3 still uses 1.4.3 version. For now, I "forced" the usage of SLF4J 1.4.3 version. I raised another task to upgrade to SLF4J 1.5.8. Revision 1054109.

          People

          • Assignee:
            jbonofre Jean-Baptiste Onofré
            Reporter:
            jbonofre Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development