Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 3.4.0
    • Component/s: None
    • Labels:
      None

      Description

      Upgrade to the latest ActiveMQ release: 5.3.1.

        Activity

        cmoulliard Charles Moulliard added a comment -

        Replacing jars of ActiveMq 5.3.0 by 5.3.1 will not be enough.

        Here is the error returned when I try them. I don't know why ActiveMq 5.3.1 generates OSGI error ??:

        Loading Apache ServiceMix from servicemix.xml on the CLASSPATH
        Caught: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'broker' defined in class path resource [activemq.xml]:
         Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [org.apache.
        activemq.xbean.XBeanBrokerService]: Constructor threw exception; nested exception is java.lang.NoClassDefFoundError: org/osgi/framework/BundleExceptio
        n
        org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'broker' defined in class path resource [activemq.xml]: Instant
        iation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [org.apache.activemq
        .xbean.XBeanBrokerService]: Constructor threw exception; nested exception is java.lang.NoClassDefFoundError: org/osgi/framework/BundleException
                at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.instantiateBean(AbstractAutowireCapableBeanFactory.java:883)
                at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBeanInstance(AbstractAutowireCapableBeanFactory.java:839
        )
                at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:440)
                at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory$1.run(AbstractAutowireCapableBeanFactory.java:409)
                at java.security.AccessController.doPrivileged(Native Method)
                at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:380)
                at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:264)
                at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
                at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:261)
                at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:185)
                at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:164)
                at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:254)
                at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:185)
                at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:164)
                at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:254)
                at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:185)
                at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:164)
                at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:423)
                at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:728)
                at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:380)
                at org.apache.xbean.spring.context.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContext.java:161)
                at org.apache.xbean.spring.context.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContext.java:51)
                at org.apache.servicemix.Main.main(Main.java:53)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                at java.lang.reflect.Method.invoke(Method.java:597)
                at org.codehaus.classworlds.Launcher.launchStandard(Launcher.java:353)
                at org.codehaus.classworlds.Launcher.launch(Launcher.java:264)
                at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
                at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
        Caused by: org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [org.apache.activemq.xbean.XBeanBrokerService]: Cons
        tructor threw exception; nested exception is java.lang.NoClassDefFoundError: org/osgi/framework/BundleException
                at org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:115)
                at org.springframework.beans.factory.support.SimpleInstantiationStrategy.instantiate(SimpleInstantiationStrategy.java:61)
                at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.instantiateBean(AbstractAutowireCapableBeanFactory.java:877)
                ... 30 more
        Caused by: java.lang.NoClassDefFoundError: org/osgi/framework/BundleException
                at org.apache.activemq.xbean.XBeanBrokerService.<init>(XBeanBrokerService.java:57)
                at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
                at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
                at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
                at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
                at org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:100)
                ... 32 more
        Caused by: java.lang.ClassNotFoundException: org.osgi.framework.BundleException
                at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
                at java.security.AccessController.doPrivileged(Native Method)
                at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
                at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
                at org.codehaus.classworlds.RealmClassLoader.loadClassDirect(RealmClassLoader.java:195)
                at org.codehaus.classworlds.DefaultClassRealm.loadClass(DefaultClassRealm.java:255)
                at org.codehaus.classworlds.RealmClassLoader.loadClass(RealmClassLoader.java:214)
                at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
                at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
                ... 38 more
        
        jb@nanthrax.net Jean-Baptiste Onofré added a comment -

        Duplicate of SM-1950.


          People

          • Assignee:
            jb@nanthrax.net Jean-Baptiste Onofré
            Reporter:
            jb@nanthrax.net Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development