Uploaded image for project: 'ServiceMix'
  1. ServiceMix
  2. SM-1456

Statistics Service throws NPE on startup.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.3.1, 3.4.0
    • Component/s: servicemix-components
    • Labels:
      None
    • Environment:

      Windows XP

      Description

      I received this exception on startup, upon some discussion on the list, it appears that maybe a service sent a message to the Statistics Service before it was ready and generated an NPE. Something should be done to prevent this from happening.

      WARN - DeliveryChannelImpl - Error calling listener: null
      java.lang.NullPointerException
      at org.apache.servicemix.jbi.monitoring.StatisticsService.onExchangeAccepted(StatisticsService.java:307)
      at org.apache.servicemix.jbi.monitoring.StatisticsService$3.exchangeAccepted(StatisticsService.java:186)
      at org.apache.servicemix.jbi.messaging.DeliveryChannelImpl.processInBound(DeliveryChannelImpl.java:598)
      at org.apache.servicemix.jbi.nmr.flow.AbstractFlow.doRouting(AbstractFlow.java:172)
      at org.apache.servicemix.jbi.nmr.flow.seda.SedaFlow.doRouting(SedaFlow.java:167)
      at org.apache.servicemix.jbi.nmr.flow.seda.SedaQueue$1.run(SedaQueue.java:134)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)

        Issue Links

          Activity

          asilchenko Anna Silchenko-Wei added a comment -

          I am getting same problem with fuse-esb-3.3.1.8 on Linux.

          gertvanthienen Gert Vanthienen added a comment -

          The previous fix introduced a NPE in the initEndpointLIstener method, new fix in rev. 708639, 708646 and 708647

          Caused by: java.lang.NullPointerException
              at org.apache.servicemix.jbi.monitoring.StatisticsService.initEndpointListener(StatisticsService.java:206)
              at org.apache.servicemix.jbi.monitoring.StatisticsService.init(StatisticsService.java:161)
              at org.apache.servicemix.jbi.container.JBIContainer.init(JBIContainer.java:608)
              at org.apache.servicemix.jbi.container.SpringJBIContainer.afterPropertiesSet(SpringJBIContainer.java:66)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1203)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1172)
              at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:427)
              at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:249)
              at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:155)
              at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:246)
              ..... 
          

            People

            • Assignee:
              gertvanthienen Gert Vanthienen
              Reporter:
              rmoquin Ryan Moquin
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development