ServiceMix
  1. ServiceMix
  2. SM-1215

CXF BC and SE cannot be run on OpenESB

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a Problem
    • Affects Version/s: 3.2.1
    • Fix Version/s: 3.2.1
    • Labels:
      None
    • Environment:

      OpenESB 2.0 preview 3 as shippend in Glassfish v2 UR1, servicemix-cxf-bc & -se from ServiceMix 3.2.1, SUN JDK1.5.0_14 on Windows XP

      Description

      The CXF BC and SE can be installed on OpenESB. However, when starting up either one of them, OpenESB complains with the following ClassNotFound exception:

      JBIFW1136: Engine servicemix-cxf-se cannot be initialized. The LifeCycle init() method threw a javax.jbi.JBIException exception. The exception message is: Error calling init
      javax.jbi.JBIException: Error calling init
      at org.apache.servicemix.common.AsyncBaseLifeCycle.init(AsyncBaseLifeCycle.java:195)
      at com.sun.jbi.framework.ComponentFramework.initializeComponent(ComponentFramework.java:1234)
      at com.sun.jbi.framework.ComponentFramework.startComponent(ComponentFramework.java:1712)
      at com.sun.jbi.framework.ComponentLifeCycle.start(ComponentLifeCycle.java:159)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.jmx.mbeanserver.StandardMetaDataImpl.invoke(StandardMetaDataImpl.java:414)
      at javax.management.StandardMBean.invoke(StandardMBean.java:323)
      at com.sun.jmx.mbeanserver.DynamicMetaDataImpl.invoke(DynamicMetaDataImpl.java:213)
      at com.sun.jmx.mbeanserver.MetaDataImpl.invoke(MetaDataImpl.java:220)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:815)
      at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784)
      at com.sun.enterprise.interceptor.DynamicInterceptor.invoke(DynamicInterceptor.java:178)
      at com.sun.jbi.management.facade.Facade.invokeRemoteVoidOperation(Facade.java:223)
      at com.sun.jbi.management.facade.ComponentLifeCycle.startComponentOnInstance(ComponentLifeCycle.java:471)
      at com.sun.jbi.management.facade.ComponentLifeCycle.start(ComponentLifeCycle.java:101)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.jmx.mbeanserver.StandardMetaDataImpl.invoke(StandardMetaDataImpl.java:414)
      at javax.management.StandardMBean.invoke(StandardMBean.java:323)
      at com.sun.jmx.mbeanserver.DynamicMetaDataImpl.invoke(DynamicMetaDataImpl.java:213)
      at com.sun.jmx.mbeanserver.MetaDataImpl.invoke(MetaDataImpl.java:220)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:815)
      at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784)
      at com.sun.enterprise.interceptor.DynamicInterceptor.invoke(DynamicInterceptor.java:178)
      at com.sun.jbi.ui.runtime.mbeans.AbstractUIMBeanImpl.invokeMBeanOperation(AbstractUIMBeanImpl.java:386)
      at com.sun.jbi.ui.runtime.mbeans.AbstractUIMBeanImpl.invokeMBeanOperation(AbstractUIMBeanImpl.java:449)
      at com.sun.jbi.ui.runtime.mbeans.JBIAdminCommandsUIMBeanImpl.startComponent(JBIAdminCommandsUIMBeanImpl.java:2427)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.sun.jmx.mbeanserver.StandardMetaDataImpl.invoke(StandardMetaDataImpl.java:414)
      at javax.management.StandardMBean.invoke(StandardMBean.java:323)
      at com.sun.jmx.mbeanserver.DynamicMetaDataImpl.invoke(DynamicMetaDataImpl.java:213)
      at com.sun.jmx.mbeanserver.MetaDataImpl.invoke(MetaDataImpl.java:220)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:815)
      at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784)
      at com.sun.enterprise.interceptor.DynamicInterceptor.invoke(DynamicInterceptor.java:178)
      at com.sun.enterprise.admin.jmx.remote.server.callers.InvokeCaller.call(InvokeCaller.java:69)
      at com.sun.enterprise.admin.jmx.remote.server.MBeanServerRequestHandler.handle(MBeanServerRequestHandler.java:155)
      at com.sun.enterprise.admin.jmx.remote.server.servlet.RemoteJmxConnectorServlet.processRequest(RemoteJmxConnectorServlet.java:122)
      at com.sun.enterprise.admin.jmx.remote.server.servlet.RemoteJmxConnectorServlet.doPost(RemoteJmxConnectorServlet.java:193)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:738)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:831)
      at org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:411)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:290)
      at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:271)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:202)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:206)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:150)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:632)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:577)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:571)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1080)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:272)
      at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:637)
      at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:568)
      at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:813)
      at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:341)
      at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:263)
      at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:214)
      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:265)
      at com.sun.enterprise.web.connector.grizzly.WorkerThreadImpl.run(WorkerThreadImpl.java:116)
      Caused by: java.lang.RuntimeException: java.lang.ClassNotFoundException: org.apache.cxf.bus.CXFBusFactory
      at org.apache.cxf.BusFactory.newInstance(BusFactory.java:153)
      at org.apache.cxf.BusFactory.newInstance(BusFactory.java:132)
      at org.apache.cxf.BusFactory.getDefaultBus(BusFactory.java:69)
      at org.apache.cxf.BusFactory.getDefaultBus(BusFactory.java:58)
      at org.apache.servicemix.cxfse.CxfSeComponent.doInit(CxfSeComponent.java:79)
      at org.apache.servicemix.common.AsyncBaseLifeCycle.init(AsyncBaseLifeCycle.java:187)
      ... 74 more
      Caused by: java.lang.ClassNotFoundException: org.apache.cxf.bus.CXFBusFactory
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1498)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:242)
      at org.apache.cxf.BusFactory.newInstance(BusFactory.java:149)
      ... 79 more

      I have checked the jbi.xml descriptor of both the SE and BC to include the relevant CXF core jar and they both do.
      Any ideas?

      Kai

        Activity

        Kai Hudalla created issue -
        Kai Hudalla added a comment -

        In order to be able to deploy any of the ServiceMix components into another JBI container like OpenESB, the servicemix-shared-compat library needs to be deployed first into the JBI container. This library, however, does not come with the standard ServiceMix distribution but can be retrieved from a Maven repository or can be built from the sources.

        Kai Hudalla made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 3.2.1 [ 11847 ]
        Resolution Not A Problem [ 6 ]
        Jeff Turner made changes -
        Project Import Sat Nov 27 00:46:19 EST 2010 [ 1290836779991 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Kai Hudalla
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development