Uploaded image for project: 'Sling'
  1. Sling
  2. SLING-9951

Add option to JCR and File Installer to override multi-version support per bundle

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Open
    • Major
    • Resolution: Unresolved
    • File Installer 1.3.0, JCR Installer 3.3.0
    • None
    • None
    • None

    Description

      When the option introduced with SLING-9172 is active, the Sling Installer will always install other bundle versions in addition, instead of updating the already deployed version. It should be possible to override this behaviour per bundle provided to the OSGi installer.

      This could e.g. be expressed with a certain name file name/node pattern, e.g. <bundlename>.update.<jar>. Both the JCR Installer and the File Installer should support it.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              kwin Konrad Windszus
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated: