Uploaded image for project: 'Sling'
  1. Sling
  2. SLING-9088

Wrong require capability makes bundle unusable

    XMLWordPrintableJSON

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Security 1.1.18
    • Fix Version/s: Security 1.1.20
    • Component/s: General
    • Labels:
      None

      Description

      The require capability for http is currently wrong in bnd.bnd, it says:
      osgi.implementation;filter:="(&(osgi.implementation=osgi.http)(version>=1.0)(!(version<=2.0)))"
      As version 1.0 is higher 1.0 but not lower than 2.0, this does not match, same for any other 1.x version
      It needs to read:
      osgi.implementation;filter:="(&(osgi.implementation=osgi.http)(version>=1.0)(!(version>=2.0)))"

        Attachments

          Activity

            People

            • Assignee:
              cziegeler Carsten Ziegeler
              Reporter:
              cziegeler Carsten Ziegeler
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: