Uploaded image for project: 'Sling'
  1. Sling
  2. SLING-9048

The HTL engine does not specify the correct io.sightly.runtime requirement version range

    XMLWordPrintableJSON

    Details

      Description

      When SLING-8471 was implemented, the transition from the maven-bundle-plugin to the bnd-maven-plugin introduced the error of defining the io.sightly.runtime requirement as:

      Require-Capability: io.sightly.runtime; filter:="(&(version<=1.0)(!(version>=2.0)))"
      

      instead of:

      Require-Capability: io.sightly.runtime; filter:="(&(version>=1.0)(!(version>=2.0)))"
      

      While in practice this doesn't affect a regular Sling setup, it should be corrected.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                radu Radu Cotescu
                Reporter:
                radu Radu Cotescu
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: