Uploaded image for project: 'Sling'
  1. Sling
  2. SLING-8735

Ignore bundle version baselining messages

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Bundle Parent 38
    • Component/s: General
    • Labels:
      None

      Description

      More recent versions of bnd also verifies the bundle version (in addition to the package versions) during baselining as recommended in https://www.osgi.org/developer/white-papers/semantic-versioning/bundles-and-fragments/.
      This is currently not useful for Sling as we still follow the odd/even release version policy for bundle versions.

      Therefore we should disable those baselining messages as adviced in https://github.com/bndtools/bnd/issues/3446#issuecomment-534098094.

      Further discussion can be found in https://lists.apache.org/thread.html/cde09fb1f483b74791e0fdaeff4fad1aee3006232062e38dcbf33e31@%3Cdev.sling.apache.org%3E

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                kwin Konrad Windszus
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: