Uploaded image for project: 'Sling'
  1. Sling
  2. SLING-8664

Sling Starter dependency import for projects built on top of it

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

      Description

      If you build projects running on top of the Sling Starter, it would be nice to have an easy way to adjust the version numbers of the dependencies that are included in the Sling Starter to the used Sling Starter version, since there are rather a lot of those. It would be nice if the Sling Starter could provide maven pom with all the dependency declarations that could be included into the project in the dependencyManagement with scope [import|https://maven.apache.org/guides/introduction/introduction-to-dependency-mechanism.html]. A switch to a new version of the Sling Starter would then just mean to the 

      As an example: we did this for our purposes in https://github.com/ist-dresden/composum-meta (see the description at "Sling Starter Dependencies") with https://github.com/ist-dresden/composum-meta/blob/develop/sling/starter/dependencies/11/pom.xml . (That might be somewhat usable for others, too, but is obviously unofficial  and mostly autogenerated.)

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              hanspeterstoerr Hans-Peter Stoerr

              Dates

              • Created:
                Updated:

                Issue deployment