Details

      Description

      The bundle depends on the old o.a.s.jcr.api 2.0.2-incubator bundle which exports the JCR API at version 1.0. With the update to the latest bundle plugin this export now causes the JUnit Scriptable Tests Provider bundle to import JCR API at (1.0,2.0] which of course does not work.

      Updating the dependency to 2.0.4 and adding JCR as an explicit dependency (inheriting the version number from dependency management) works.

        Activity

        Felix Meschberger created issue -
        Felix Meschberger made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s JUnit Scriptable Tests Provider 1.0.8 [ 12316661 ]
        Resolution Fixed [ 1 ]
        Carsten Ziegeler made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Gavin made changes -
        Workflow no-reopen-closed,doc-test-required [ 12668543 ] Copy of no-reopen-closed,doc-test-required [ 12765221 ]
        Gavin made changes -
        Workflow Copy of no-reopen-closed,doc-test-required [ 12765221 ] no-reopen-closed,doc-test-required [ 12766985 ]
        Gavin made changes -
        Workflow no-reopen-closed,doc-test-required [ 12766985 ] re-open possible,doc-test-required [ 12788713 ]
        Gavin made changes -
        Workflow re-open possible,doc-test-required [ 12788713 ] no-reopen-closed,doc-test-required [ 12793062 ]

          People

          • Assignee:
            Felix Meschberger
            Reporter:
            Felix Meschberger
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development