Sling
  1. Sling
  2. SLING-2431

jre-1.6.properties and jre-1.7.properties are missing a lot of packages

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Launchpad
    • Labels:
      None
    • Environment:
      CQ 5.5 GA

      Description

      The jre-1.6.properties and jre-1.7.properties files in trunk ( http://svn.apache.org/repos/asf/sling/trunk/launchpad/base/src/main/resources/ ) are missing most of the new Java 6/7 packages.

      The 1.6.properties is basically a copy of the 1.5.properties file plus a couple of additional (annotation, lang.model, script, tools) packages. The 1.7.properties adds javax.swing.plaf.nimbus compared to the 1.6.properties. But most of the other javax packages (like jws, xml, activation - and all of their sub-packages) are missing in both files.

      I found a more accurate list in the jre-1.6/jre-1.7 sections of http://svn.apache.org/repos/asf/felix/trunk/framework/src/main/resources/default.properties (these lists are just missing org.w3c.dom.css, org.w3c.dom.html, org.w3c.dom.ranges, org.w3c.dom.stylesheets,org.w3c.dom.traversal,org.w3c.dom.xpath).

      I suggest to update these files accordingly.

      As a workround one can take the source of a framework-extension-* bundle and modify as needed. (Modification needed because they are a) also missing some packages and b) they are not Java version specific.)

        Issue Links

          Activity

          Gavin made changes -
          Workflow re-open possible,doc-test-required [ 12788507 ] no-reopen-closed,doc-test-required [ 12791182 ]
          Gavin made changes -
          Workflow no-reopen-closed,doc-test-required [ 12766557 ] re-open possible,doc-test-required [ 12788507 ]
          Gavin made changes -
          Workflow Copy of no-reopen-closed,doc-test-required [ 12762753 ] no-reopen-closed,doc-test-required [ 12766557 ]
          Gavin made changes -
          Workflow no-reopen-closed,doc-test-required [ 12655704 ] Copy of no-reopen-closed,doc-test-required [ 12762753 ]
          Felix Meschberger added a comment -

          For reference, SLING-2109 is the issue removing the XML releated packages from the properties file and adding the XML API fragement.

          Felix Meschberger made changes -
          Link This issue relates to SLING-2109 [ SLING-2109 ]
          Justin Edelson made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Won't Fix [ 2 ]
          Justin Edelson added a comment -

          this is by design - you should use the framework extension bundles or roll your own.

          Mike Pfaff created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Mike Pfaff
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development